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1.1 General Description 
It is beyond the scope of this document to discuss methods of construction, but it is certainly appropriate to 
emphasize the importance and influence of these methods.  While past failures of drilled shafts to perform 
properly under axial loading have been relatively rare, the difficulties that have been reported, almost 
without exception, have been related to errors in construction.  Therefore, the user of the SHAFT software 
is urged to give careful attention to the preparation of construction specifications and to the performance of 
field inspection by qualified personnel to ensure that good construction is achieved. 

At the present time it is well established that drilled shafts can carry a substantial portion of their load in 
skin friction or side resistance.  Much of the data from field tests of instrumented drilled shafts show that 
the initial loads are sustained almost completely by skin friction.  Usually, at a relatively small downward 
movement, the full resistance in skin friction is mobilized and the remaining load is carried in end bearing.  
At the ultimate load, a sizeable portion may be carried in end bearing but at a significant amount of 
downward movement of the drilled shaft.  In some instances, there is some reduction in the load carried in 
side resistance as the downward movement is continued, due probably to the reduction in shear strength of 
the soil along the sides of the shaft.  Thus, the designer must take into account the amount of downward 
movement and the resulting influence on load transfer when both end bearing and skin friction are being 
counted on. 

As noted above, tests of instrumented drilled shafts have allowed the load that was transferred to the soil in 
skin friction (side resistance) to be measured and correlations have been developed between the skin friction 
and soil properties.  The scatter in the correlation is relatively small where excellent methods of construction 
were employed.  However, there are several reasons to use caution in making designs that depend strongly 
on skin friction: the number of instrumented tests is relatively small, there are some types of soil where 
tests have not been performed, and the load transfer in skin friction is influenced strongly by construction 
procedures.  Therefore, designs that make use of skin friction must be made with care or field load tests 
must be made to prove the design or to obtain revised design parameters. 

SHAFT is a special-purpose program based on rational procedures for analyzing a drilled shaft and 
continuous flight auger piles under axial loading.  The program computes settlement of the top and base of 
the shaft as a function of axial loading, along with the distribution of axial load along the length of the shaft. 

1.2 History of Development 

1.2.1 SHAFT1 (1987) 

With the advent of wide-spread availability of personal computers, the founder of ENSOFT, Inc., had a 
vision to improve the engineering capability for analysis and design of deep foundations by providing useful 
and practical software tools.  The development of SHAFT1 was completed under the direction of Dr. Lymon 
C. Reese and was first commercially distributed in 1987.  While based on an earlier mainframe program, 
SHAFT1 was developed to use an interactive input method in DOS. 

1.2.2 SHAFT, Version 2 (1989) 

Version 2 of SHAFT was released in 1989.  This version incorporated the improved methods of analysis 
developed by Reese and O’Neill (1988).  In addition, a new menu-based DOS interface was introduced. 
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1.2.3 SHAFT 3.0 for Windows (1995) 

The success of Windows 3.1 from Microsoft, Inc., as the dominant platform for personal computers pushed 
software development to adopt a standard, graphical-user interface.  This version of SHAFT utilized 
Windows-based pre-and post-processors, while retaining the original computation engine from Version 2. 

1.2.4 SHAFT 4.0 for Windows (1998) 

SHAFT 4.0 was a complete recoding of both the pre-and post-processing programs running under Windows 
95/NT and the computation engine.  The graphical-user interface was coded to provide a more intuitive 
process for data input and to enhance the graphical capabilities. 

In addition, in the technical side, Version 4 includes new capabilities to analyze drilled shafts in 
intermediate geomaterials, such as gravel and soft rock.  Version 4 was capable of automatically computing 
capacities for shaft subjected to uplift forces. 

1.2.5 SHAFT 5.0 for Windows (2001) 

This version of SHAFT has been improved over the previous version in that the computational methods 
have been updated to conform to the recommendations by the Federal Highway Administration (FHWA, 
1999).  In addition, the graphical output features have been updated to allow the user to plot both the 
ultimate and service load cases for the shaft.  SHAFT 5.0 also included an updated help file that contained 
information on all areas of the program where the user is asked to input information, as well as information 
on program output. 

1.2.6 SHAFT 6.0 for Windows (2007) 

SHAFT Version 6.0 added new soil criteria for computing the axial capacity of drilled shafts in strata of 
gravelly sand and gravel based on the studies by Rollins et al (2005).  Another new feature in Version 6.0 
is to allow the user to include both side friction and tip resistance for drilled shafts in strong rock (for 
comparative purposes).  The load-versus-settlement curve at the top of drilled shafts in soils had become 
important for structural engineers in specifying the stiffness of the foundations.  The new version of SHAFT 
allowed users to compare the upper-bound, lower-bound, and trend (averaged) curves together for 
engineering assessment.  The user may specify the increment length, such as 1 ft, 2 ft, 1 m, or 2 m, for 
printing the output.  SHAFT Version 6.0 also generates t-z curves for each soil layer and saved the data in 
an external file.  The graphics allow the user to present the soil profile along the predicted pile capacity as 
a function of depth. 

1.2.7 SHAFT 2012 (v7) 

The SHAFT program used the year number in the version sequence starting in 2012.  The major 
improvement in v2012 was to provide options for specifying the reduction factors on side friction and tip 
resistance for each soil/rock layer if the user selects the LRFD method for design.  The option for the 
conventional Allowable Stress Design (ASD) method through specifying factors of safety is still available 
in SHAFT 2012.  The program allows the user to change the line width and font sizes in the generated plots.  
In addition, the v2012 release introduced compatibility to Windows 8.  The program text book was updated 
and released in separate User’s and Technical Manuals, both improved plus released electronically in 
protected PDF format. 
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1.2.8 SHAFT 2017 (v8) 

A number of major improvements were implemented in SHAFT v2017 (equivalent to SHAFT v8 when 
using the old release numbering). 

1.2.8.1 Computational Changes 
1. New option to generate curves of load settlement with pile penetration. 
2. New option to generate design curves (capacity vs penetration/diameter) for specified 

settlements. 
3. New option to estimate side friction using Kulhawy and Chen Method for Sand. 
4. Expanded computations of side resistances for sand based on SPT blow counts (when 

provided). 

1.2.8.2 Interface Changes 
5. Added a new option to display elevations instead of depth for vertical axes in all applicable 

plots. 
6. This release also includes a change in the data format for the input data files (now using the 

extension “sf8d” for the new input-data files).  An input-data converter is introduced to read 
older data files and make them compatible to the new format. 

7. Updated interface and speed buttons. 
8. New prints of t-z curves and Q-w curves as text in file extension “sf8z”.  Depending on the 

model type, the new t-z curves may correspond to maximum shaft length, initial shaft diameter 
and for averaged values.  Depending on the model type, the new Q-w curves may correspond to 
maximum shaft length, various shaft diameter and for averaged values. 

9. Added a new 3D view window where users can choose to see the soil layers, depths and load 
transfers with depth for the modeled shaft. 

1.2.8.3 File Handling Changes 
10. The File > Open dialog box has been updated with more user-friendly features for navigation. 
11. Any of the output graphics from the new SHAFT program can be exported to a pre-formatted 

spreadsheet with multiple descriptive tabs. 
12. t-z and Q-w curves outputted by the program or at depths required by the user can now be 

exported to text or pre-formatted spreadsheet.  Depending on the model type, the new t-z curves 
may correspond to maximum shaft length, initial shaft diameter and for averaged values.  
Depending on the model type, the new Q-w curves may correspond to maximum shaft length, 
various shaft diameter and for averaged values. 

1.2.9 SHAFT 2023 (v9) 

The most important improvements implemented in SHAFT v2023 (equivalent to SHAFT v9 when using 
the old release numbering) are included in the list below. 

1. Introduced computational methods for estimating the axial capacity of continuous flight auger 
(CFA) piles.  CFA pile capacity is estimated using recommended methods for Clay and Sand: 

 - Reese & O’Neill Method (Using Undrained Shear Strength or SPE Values) 
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 - Coleman and Arcement (2002) Method (Using CPT or SPT Values) 
 - Laboratorie Des Ponts et Chausses (LPC) method (Using CPT Values) 
2. Expanded the Sand (FHWA) criteria by adding recommendations from GEC-10 using the 

values from Over Consolidation Ratio. 
3. Added the Brown et al (2018) GEC-10 criteria for FHWA Clay & Shale to the existing FHWA 

criteria from Reese & O’Neill (1988).  Users now have the option to select entries of undrained 
cohesion based on three different laboratory tests: unconfined compression (UC) test, 
unconsolidated undrained (UU) triaxial compression, and consolidated isotropically undrained 
triaxial compression (CIUC). 

4. Improved the scaling and presentation of plots in models with negative elevations (instead of 
depths). 

5. All changes to plot/graphics (titles, legends, etc) done by the user are now associated and saved 
with the SHAFT model. 

6. Users are now able to open the new v2023 Technical Manual in standard PDF file format. 
7. Minor changes were also made throughout the program interface to improve data input and 

output displays. 

1.3 Organization of SHAFT Manuals 
The documentation provided with the computer program SHAFT consists of two volumes.  The User’s 
Manual contains full documentation about the operation of the program on personal computers.  The User’s 
Manual covers the areas of installation, preparation of input data, program execution, view of computational 
results, and example applications.  The distribution of the User’s Manual is made via standard & 
unprotected Adobe© PDF file format. 

The Technical Manual provides information about the theories of load-transfer and settlement of drilled 
shafts in different types of soil/rock strata.  The Technical Manual includes other helpful references related 
to concepts utilized in program SHAFT.  ENSOFT holds a copyright of the Technical Manual so it is 
distributed in protected form that can only be opened by licensed users of the SHAFT program. 

Both Manuals are installed with the SHAFT program and accessible via any one of the following three 
methods: i) from the Windows Start Menu, ii) from the Ensoft tile in Windows 10, 8 and 8.1, or iii) from 
the Help menu within the SHAFT program. 

1.4 Typographical Conventions  
To orient the user to different program features, certain terms are set in typefaces that distinguish them from 
the body text.  The following formatting conventions are used throughout the manuals: 

• Commands that are typed directly on the keyboard: “Enter” ; “F1” ; “Esc”  

• Commands with keys simultaneously pressed in the keyboard: “Alt+F” ; “Ctr+O”  

• Menu items and other text displayed on the screen are in sans serif:  
From the File menu choose Open  

• File names and names of directories and folder and icon names are in italics:  
Open the example file example1.sf9d 
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• Internet and electronic mail addresses are underlined: 
Send email to support@ensoftinc.com 

1.5 Contents of the SHAFT Package 
The standard package sent with SHAFT consists of the following items: 

• One USB Key (sometimes known as hardware key or dongle), 

• One USB Memory Stick (this contains installation routines for the most recent release of 
SHAFT, as well as other Ensoft programs, at the time of shipment) 

1.6 Default Installation Directories 
The directories for installation of program files and for example files are selected by the user during 
program installation.  Default values are provided by the installer and confirmed or changed by the user. 

1.6.1 Directory for Main Program Files 

Program files are installed by default in the following directory: 

Root Drive:\Program Files (x86)\Ensoft\Shaft2023 

In most cases the Root Drive is the c:\ drive so the default is: 

c:\Program Files (x86)\Ensoft\Shaft2023 

Main program files are the following: 

winsh2023.exe is the main Windows-program module (executable/application), 

SHAFT2023_DLL.dll  is the program engine for direct computations, 

User’s and Technical Manuals are also included in the main installation directory. 

1.6.2 Directory for Example Files 

Several modeling examples with input files (files with name/extension of the type filename.sh9d) are 
installed on a separate folder that defaults to: 

Root Drive:\Ensoft\Shaft2023-Examples 

In most cases the Root Drive is the c:\ drive so the default is: 

c:\Ensoft\Shaft2023-Examples 

1.7 Hardware Requirements  
To use SHAFT, the user needs the following minimum hardware configuration:  

• Any personal computer with an Intel® Pentium® or newer processor. 

• A hard disk with at least 50 MB of free space. 
• Microsoft Windows® 2000, XP, VISTA, Windows 7, Windows 8, Windows 8.1, Win 10 or 

Windows 11.  A newer release of the Microsoft Windows® operating system may need a more 
recent update of the SHAFT software. 

mailto:support@ensoftinc.com
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• Minimum of 640 KB of free RAM memory. 

• Open (available) USB port (v2 or newer). 

• A mouse or similar pointing device. 
• Optional: Any windows-compatible printer. 

1.8 Technical Support 
Although computer program SHAFT was designed to be distinguished by its ease of use and by the 
accompanying User’s and Technical Manuals, some users may still have questions.  The technical staff at 
ENSOFT strongly supports all licensed users with questions related to the installation or use of SHAFT.  
For instance, we evaluate and troubleshoot when a specific model (input data file) provides some errors or 
when users have a specific question regarding an apparent discrepancy of results when comparing two 
different models/scenarios. However, our free services of technical support do not include free training or 
technical interpretations that would require engineering judgment. 

New software purchases include free maintenance service for the first year (included in purchase price).  
After the first year the user is encouraged to purchase/renew the services for yearly maintenance.  The 
yearly maintenance services include free download of the latest version and free technical support (as 
explained earlier). 

1.8.1 Preferred Methods of Software Support  

Software support is given, in order of preference, by the following methods:  

• Electronic mail to: support@ensoftinc.com 
• Fax to: (512) 244-6067 

• Telephone call to: (512) 244-6464, extension 2 

Users are strongly encouraged to utilize electronic means of support via email.  In all technical support 
requests via email, please include the following information: 

• full software version/release/update (obtained from the Help > About dialog), 
• a description of the user’s problem or concern, 

• attach a copy of the input-data file that is associated with the issue/concern (files with 
name/extension of the type filename.sf9d), and  

• name and telephone number of the contact person and of the licensed user (or name and office 
location of the licensed company site and/or serial number of the USB Key). 

Although immediate answers are offered on most technical support requests, please allow up to two 
business days for a resolution in case of difficulties or schedule conflicts. 

Technical help by means of direct calls to our local telephone number, (512) 244-6464, is available, but is 
limited to the business hours of 9 a.m. to 5 p.m. (US central time zone, UTC −6:00). The current policy of 
Ensoft is that all telephone calls for software support will be answered free of charge if the user has a valid 
maintenance contract. 

mailto:support@ensoftinc.com
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1.8.2 Upgrade Verification and Internet Site  

Starting from SHAFT v2012 the software provides options for the user to check the most recent 
maintenance release through an internet connection by selecting Help > Check for Updates from within 
the software.  This command starts the default internet browser and will display the user’s maintenance 
expiration date, the user’s software release number and the most recent release number that is available for 
downloading. 

If the user’s version is not the latest version and the maintenance has not expired, the user can download 
the latest version from our web server directly (www.ensoftinc.com).  Users may also consult our internet 
site for additional information on software updates, demos, and new applications; technical news; and 
company information. 

1.8.3 Renewal of Program Maintenance 

The cost to renew program maintenance will depend on the length of time for which the program 
maintenance has been expired.  There are small price increases with time after expiration.  The pricing 
policy for renewing a program maintenance that has not expired can be found on the Ensoft website at 
https://www.ensoftinc.com/order_form 

1.8.4 Changes of Support Policy  

The software support policy and associated expenses are subject to change at ENSOFT’s discretion and 
without specific mailed notices to the users. However, any change of rules will be verbally provided during 
telephone calls for software support.  
 

http://www.ensoftinc.com/
https://www.ensoftinc.com/order_form
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2.1 Installation Procedures 
Program SHAFT is distributed with an associated USB Key (hardware key or dongle).  The USB Key 
consists of a device that is attached to an empty USB port (or USB hub) of the computer in use (or in the 
designated software server in the case of local network licenses).  This method of software protection has 
been found to provide compatibility with existing operating systems, better stability than other alternatives, 
and allows users to obtain software updates or replacements via downloads from the internet. 

Users with standard single-user licenses can check the following link to a PDF with Installation Notes: 
https://www.ensoftinc.com/doc/Ensoft_Single-User_License_Installation_Booklet.pdf 

Users with local network licenses can check the following link to a PDF with Network Installation Notes: 
https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf 

2.1.1 Installation of Single-User Version 

This version of SHAFT has been tested to be compatible with the following versions of the Microsoft 
Windows® operating systems: 2000, XP, Vista, and Windows 7 and 8, 8.1, 10 and 11 in 32 and 64-bit 
releases. 

The following guidelines are recommended during the installation process of LPILE for single-user 
licenses. 
1. Plug the supplied USB Key into one of the available and working USB ports in your computer.  The 

USB Key is plug-and-play compatible so the operating system will recognize the USB Key 
automatically and a small but solid green light should appear at the end of the USB Key (a flickering 
green light or no light indicate problems with the standard windows driver or with the USB Key). 

2. If the user installs from a distribution USB Memory Stick and the main installation program does not 
start automatically upon insertion of the Memory Stick then click on the Windows Start Menu 
button and select Run.  On the command line, type d:\setup.exe or e:\setup.exe, where d: or e: 
represents the drive that contains the distribution Memory Stick.  Click OK to execute the command 
and start the main installation program for ENSOFT’s software.  A screen similar to the one in 
Figure 2.1 should appear. 

3. If the user installs from a downloaded file, then please run the downloaded file (double click) and go 
to instruction #5. 

4. Click anywhere on the Shaft 2023 icon and then click on the Install Standard button to start the 
installation of SHAFT. 

5. The user should read the license agreement shown in Figure 2.2.  Users can review the License 
Agreement online in the following link: 

https://www.ensoftinc.com/doc/Ensoft%20License%20and%20Disclaimer.pdf 
The installer will place the same file (Ensoft License and Disclaimer.pdf) in the installation 
directory.  Please click Yes if you agree and would like to proceed. 

6. Select Single-User License in Figure 2.3 then click Next.  For network installations please contact 
Ensoft support (support@ensoftinc.com). 

7. The user will be provided with an option to select a drive and directory for the installation of 
example files (see Figure 2.4).  Default installation directory is the following: 

https://www.ensoftinc.com/doc/Ensoft_Single-User_License_Installation_Booklet.pdf
https://www.ensoftinc.com/doc/Ensoft_Network_License_Installation_Booklet.pdf
https://www.ensoftinc.com/doc/Ensoft%20License%20and%20Disclaimer.pdf
mailto:support@ensoftinc.com
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(Root Drive):\Ensoft\Shaft2023-Examples 
8. The user will also be asked to select a drive and directory for the installation of LPILE (see Figure 

2.5).  Default installation directory (varies according to the Windows release where it is installed) is 
one of the following: 
(Root Drive):\Program Files (x86)\Ensoft\Shaft2023 
(Root Drive):\Program Files\Ensoft\Shaft2023 
If the desired directory does not exist, the installation program will automatically create a new 
directory in the chosen hard drive. 

 

Figure 2.1   Main installation screen for ENSOFT software (may change with time) 

9. During the installation the user will be asked to set the file extension association for opening SHAFT 
v2023 input data files (see Figure 2.6).  If the user agrees (leaves the default check mark) then 
double clicking (or running) any input data file with extensions of the type filename.sf9d will start 
the installed SHAFT v2023 software. 
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10. The user will be prompted to confirm the shortcut directory name that will be created in the 
Windows Start Menu (See Figure 2.7).  The default is Start Menu/Programs/Ensoft/Shaft2023.  
Windows 11, 10 and 8 will automatically create an Ensoft tile with the same shortcuts. 

After the installation is finished, it is usually not necessary to reboot Windows for the program to run.  The 
user may run the program by selecting Shaft v2023 from the standard links installed in the Microsoft 
Windows® Start Menu:  Start Menu > All Programs > Ensoft > Shaft2023 
 

 
Figure 2.2   Installation screen with License Agreement (may change with time)  
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Figure 2.3  Selection of Single-User License (may change with time)  

 

Figure 2.4  Default Installation Directory for Example Files (may change with time) 
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Figure 2.5   Default Installation Directory for Program Files (may change with time)  

 

Figure 2.6   File Extension Association for Shaft Data Files (may change with time)  
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Figure 2.7   Default Shortcut Folder in Windows Start Menu (may change with time)  

2.1.2 Introduction of Network Version 

Special network licenses and Net USB Key (network hardware key) are available for users that desire to 
operate SHAFT on a Windows network.  The network version is limited to users within a limited range of 
IP addresses that are employed at a named licensed office site. 

Network versions of SHAFT have special subroutines written for installations in “software servers” 
(License Servers) and for installations of “individual clients” (Client Computers).  The “software server” is 
the computer that will be carrying the network key provided by ENSOFT, INC.  The software server is not 
necessarily the same as the existing network server.  Any computer in the existing Windows network may 
be designated software server for SHAFT as long as the Net USB Key is attached to a working USB port 
(or through an USB hub) and the “server” version of the software or of the Ensoft Utilities is installed on 
its hard drive. 

Software “clients” are other computers of the network that are accessed by employees of the licensed office 
site and that have the software installed as client.  Client computers do not need any hardware key or dongle 
attached to their local system.  The program installed in “client computers” will be allowed to run as long 
as the computer designated as “software server” is accessible on the network with the proper operating 
system and with its network key secured in place. 

2.1.2.1 Installation of Network Version 

Installers of network licenses should refer to a separate booklet with installation instructions for the 
Network version of this product.  The document can be downloaded from the Ensoft web site 
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(http://www.ensoftinc.com/updates/Ensoft Network Installation Notes.pdf) or can be requested via email 
to support@ensoftinc.com 

2.1.2.2 Silent Installations on Client Computers 

For installation of network licenses on local client computers there is an option for command-based 
installations that are completely silent (performed without other user input).  Instructions for silent 
installations on client computers can be downloaded from the Ensoft web site using the following link: 

http://www.ensoftinc.com/updates/Silent Install on Client Computers.pdf 

Alternatively, the document can be requested via email to support@ensoftinc.com 

2.1.3 Backup of Original Software 

The distributed software may be copied for backup purposes. The program may be installed in several 
computers at the same time.  However, unless network licenses are purchased, the program will only operate 
in computers that carry the appropriate hardware key. 

2.1.4 Software Updates on the Internet 

Occasionally, ENSOFT will produce software improvements and/or fixes and place the latest software 
programs on ENSOFT’s internet site.  Users can check for available updates by selecting Help > Check 
for Updates from the SHAFT menu.  Software users may freely download the latest program update from 
the PRODUCTS > Downloads link in the following site:  http://www.ensoftinc.com 

2.2 Getting Started 
A general diagram showing the menu choices and operational flow chart of program SHAFT is presented 
in Figure 2.8.  The following paragraphs provide a short description of the operational features of SHAFT 
and should quickly enable the user to get started with the program.  

http://www.ensoftinc.com/updates/Ensoft%20Network%20Installation%20Notes.pdf
mailto:support@ensoftinc.com
http://www.ensoftinc.com/updates/Silent%20Install%20on%20Client%20Computers.pdf
mailto:support@ensoftinc.com
http://www.ensoftinc.com/
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Figure 2.8  Sample organization and operational flow chart for SHAFT 

2.2.1 Starting the Program 

The program is started by double clicking the left mouse button anywhere in the SHAFT icon.  A new 
blank window will appear on the screen, with the following top-menu choices: File, Data, Computation, 
Graphics, Window, and Help. 

As a standard Windows feature, pressing the “Alt” key displays the menu operations with underlined letters.  
Pressing the underlined letter after pressing “Alt” is the same as clicking the operation.  For example, to 
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open a New File, the user could press “Alt+F” followed by “N”, or “Ctrl+N”, or click File then New.  
Additionally, holding the mouse cursor over an icon displays the icon function. 

2.2.2 File Management 

The File menu option contains five submenus, as shown in Figure 2.9; they are: 
• New  to create a new data file. 
• Open… to open an existing data file. 
• Save  to save input data under the current file name. 
• Save As… to save input data under a different file name. 
• Exit  to exit program SHAFT. 

A history list of up to the last ten recently-opened data files is located between the Save As and the Exit 
options.  This list varies on each user’s computer and allows for easy access to recent data files. 

 

 
Figure 2.9   Sample File Menu 

Several additional files are created in every new SHAFT run. A general description of these files is 
presented in Table 2.1.  Every run of SHAFT thus generates four text files in the same drive and directory 
where the input-data file was saved or opened.  Any of these files may be opened with standard text editors 
or word-processing programs. 
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File Name 
Extension 

Usage 
Description 

File  
Format 

Example  
Files 

*.sf9d Input-data file Text file example1.sf9d 
example2.sf9d 

*.sf9o Output-data file Text file example1.sf9o 
example2.sf9o 

*.sf9p Plot-data file Text file example1. Sf9p 
example2. Sf9p 

*.sf9r Processor-data file Text file example1. Sf9r 
example2. Sf9r 

Table 2.1   Files created in SHAFT runs 

2.2.3 Data Input of Application Problem 

The Data menu contains several choices of submenus, as shown in Figure 2.10.  The choices are listed 
below, along with a general description of their use. 

Title ..................  to enter a single line of text with a general description for the project. 

Units ................ this option allows the user to select either English Units (using pounds, feet, and inches) 
or SI Units (using kiloNewtons and meters) or any other consistent set of units of force 
and length.  English units are enabled, as a default, for all new data files.  The user may 
change the system of units as many times as desired and values that were previously 
inputted will be automatically converted by the program. 

Design Method (ASD or LRFD) ...... users may select the Allowable Stress Design (ASD) or the Load 
and Resistance Factor Design (LRFD) for the model. 

Drilled Shaft/CFA Pile Properties .... …to describe dimensions, and material properties of a drilled shaft 
or for a continuous flight auger (CFA) pile. 

Soil Layer Data .............. this is used to define the type and depth of each soil/rock layer and to enter the 
associated mechanical properties for each soil/rock layer. 

Factor of Safety (Allowable Stress Design)….here the user enters the factor of safety that will be used 
during computations with ASD method (menu is disabled for LRFD method). 

Computation Methods .. this submenu is used to select the analysis for a specific shaft length or for a 
specific design load. 

Water Table .... this is used to specify the depth of the water table. The depth of water table is referenced 
from the ground surface or finished grade. 

Evaluate Multiple Shaft Lengths ..... (optional entry) users can choose to evaluate multiple shaft 
penetrations in one single model to see a graphical representation of pile capacities for 
various lengths (this menu is disabled if the user selects ASD/LRFD Design Charts). 

ASD/LRFD Design Charts ............... (optional entry) these are design aids for either ASD or LRFD 
methods, containing pile capacity charts for user-specified pile-head settlements for 
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various pile diameters and/or pile penetrations (this menu is disabled if the user selects 
Evaluate Multiple Shaft Lengths). 

Control Options… .......... (optional entry) includes various optional control parameters that users may 
choose for certain analyses.  Available options in this menu include choosing elevation 
instead of depth measurements, printing of t-z curves at specified depths, analytical option 
for end bearing in sands and text editor. 

 

 
Figure 2.10   Data Menu 

2.2.4 Computation Options 

The Computation menu is provided to run the analytical computations after all data are entered and saved.  
After the computation is executed successfully this menu also provides options for the reviews of plain-text 
input data, notes produced during computation, and output data.  It also provides selections for the graphical 
observation of the modeled pile and soil layers.  Submenu choices, shown in Figure 2.11, are briefly 
described below. 

Run Analysis ..  ............... this is chosen to run the analytical computations.  This option should be selected 
after all data have been entered and saved. 

Edit Input Text  ............... this is to use the Text Editor (selected under Data > Control Options) to 
observe and/or edit the analytical input data in plain-text format. 

Edit Processor-Run Notes ............... in this selection the chosen Text Editor (selected under Data > 
Control Options) is used to observe, format, and/or print the notes provided during 
processing.  This selection only becomes available after a computational run.  The user is 
encouraged to read the processor-run notes if the model is not running successfully.  The 
processor-run notes may provide the user with some additional information about possible 
causes of the problem. 
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Edit Output Text ............. the chosen Text Editor (selected under Data > Control Options) is used here 
to observe, format, and/or print the analytical-output data.  This selection only becomes 
available after a successful run has been made.  Certain output files may be too large for 
the Microsoft Notepad editor, so other text editors would have to be used (Microsoft Word 
Pad should be able to open most text files). 

View Shaft Elevation ..... here users can see a simple graphical representation of the elevation of the 
modeled shaft and the location of the specified soil layers. 

3D View ........... this selection allows the modeler to see a more descriptive graphical representation of the 
shaft elevation, soil layers, depths and also charts of load transfers (available only after a 
successful run).  When in 3D View users have access to the Show 3D View menu that 
allows for the various display options. 

 

 

Figure 2.11  Computation Menu 

2.2.5 Graphics 

The Graphics menu is used to observe plots of output data after a successful program run.  Options for the 
observation of output curves under this menu are only enabled after a successful run has been made.  Even 
after performing successful runs, some selections may be disabled since the output data depends on 
specifications provided in the input file of each program run.  Submenu choices, shown in Figure 2.12, are 
briefly described below. 

Ultimate Skin Friction vs. Depth ...... provides a plot of ultimate skin friction on the modeled shaft versus 
depth. 

Ultimate Tip Resistance vs. Depth…. provides a plot of ultimate end bearing on the modeled shaft versus 
depth. 

Ultimate Total Capacity vs. Depth…. provides a plot of the ultimate total capacity (skin friction + tip 
resistance) of the modeled shaft versus depth. 

Combined Plots vs. Depth…. provides a plot of ultimate skin friction, ultimate tip resistance, and the 
ultimate total capacity versus depth all combined on the same plot.  If a model uses multiple 
shaft lengths the combined plot is only provided for the initial length.  If a model uses 
multiple shaft diameters the combined plot is only provided for the initial diameter. 
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ASD/LRFD Skin Friction vs. Depth…. provides a plot of skin friction on the modeled shaft versus depth 
with the specified factor of safety (ASD) or the specified resistance factors (LRFD). 

ASD/LRFD Tip Resistance vs. Depth…. provides a plot of top resistance of the modeled shaft versus 
depth with the specified factor of safety (ASD) or the specified resistance factors (LRFD). 

ASD/LRFD Total Capacity vs. Depth…. provides a plot of the total capacity (skin friction + tip 
resistance) of the modeled shaft versus depth with the specified factor of safety (ASD) or 
the specified resistance factors (LRFD). 

Combined Plots vs. Depth…. provides a plot of skin friction, tip resistance, and the total capacity versus 
depth on the same plot all with the specified factor of safety (ASD) or the specified 
resistance factors (LRFD).  If a model uses multiple shaft lengths the combined plot is only 
provided for the initial length.  If a model uses multiple shaft diameters the combined plot 
is only provided for the initial diameter. 

Axial Load vs. Settlement (Averaged)…. provides a plot of the axial loads versus settlement at the shaft 
head based on the averaged trend. 

Axial Load vs. Settlement (Upper Bound)… provides a plot of the axial loads versus settlement at the 
shaft head based on the upper-bound data. 

Axial Load vs. Settlement (Lower Bound)…. provides a plot of the axial loads versus settlement at the 
shaft head based on the lower-bound data. 

Combined Plots of Load vs. Settlement…. provides a plot of the axial loads versus settlement curves at 
the shaft head based on the upper-bound, lower-bound, and averaged trend data.  If a model 
uses multiple shaft lengths the combined plot is only provided for the initial length.  If a 
model uses multiple shaft diameters the combined plot is only provided for the initial 
diameter. 

t-z Curves…. provides a plot of the load-transfer curves in side resistance that are printed for 
approximately four depths on each soil layer that was defined in the model.  The plotted t-
z curves correspond to the averaged trend and also for the initial shaft diameter (if the 
model uses multiple shaft diameters). 

Q-w Curves…. provides a plot of the load-transfer curves in end bearing that are printed for each shaft 
diameter (if the model uses multiple shaft diameters).  The plotted Q-w curves correspond 
to the averaged trend. 

Additional t-z Curves…. optional plot of the load-transfer curves in side resistance that are printed for 
user-defined depths (in Data > Control Options > Print Additional t-z Curves).  The 
plotted t-z curves correspond to the averaged trend and also for the initial shaft diameter (if 
the model uses multiple shaft diameters). 

Design Chart (xx movement)…. optional plots of design charts for each user-defined (xx) movements 
(defined under Data > ASD/LRFD Design Charts). 

Exports Plots to Excel…. allows the user to export some (or all) of the above plots to an excel file.  Each 
plot will be exported to two sheets, one contains the data and the second the chart. 
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Figure 2.12   Sample Graphics Menu 

2.2.6 Arrangement of Windows 

The Window menu provides two standard functions for organizing open- screen windows and/or minimized 
screen-window icons.  Submenu options, shown in Figure 2.13, are briefly described below. 

Cascade .......... this option organizes all open-windowed menus so that all become visible with their tops 
cascading from the top left portion of the screen. 

Arrange Icons .  ............... this option organizes the icons of all minimized windowed menus so that all 
become visible and aligned at the bottom portion of the screen. 

Other entries under the Windows menu are names of any open windows or plot file, that the user may 
select to navigate between open windows. 
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Figure 2.13   Window Menu 

2.2.7 Help Menu 

 The Help menu provides an online help reference on topics such as: using the program, entering 
data, information about variables used in the program and methods of analyses.  Submenu options, shown 
in Figure 2.14, are briefly described below.  The menu may be accessed at any time while in SHAFT. 

Contents ......... the main reference files for help are accessed through this submenu option.  The Help files 
usually do not provide as much information as the electronic manuals that are also 
accessible from the Help menu. 

User’s Manual  ............... this selection calls the installed version of Adobe Acrobat or Acrobat Reader to 
open the User’s Manual.  This document is formatted as an Adobe PDF file. 

Technical Manual ..........  this selection calls the viewer of the Technical Manual.  This is a protected file 
(for a copyright document) that can only be opened with this viewer and by user’s that are 
running the program in full mode. 

About.. ............. this screen describes the program version, date, maintenance expiration date, USB serial 
number and methods for accessing technical support. 

Check for Updates ........ starts the default Internet browser and sends the user to a page that describes 
information about the user’s license (release and maintenance expiration date) as well as 
the latest release that is available for downloading at the Ensoft site.  Users may only run 
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in full mode maintenance updates that were released before the expiration date of the user’s 
license. 

   
 a. Single-User License b. Client on Local Network License 

Figure 2.14   Help Menu 

Ensoft Key Inquirer........ this selection is only available for single-user licenses (not available in local 
network licenses). This utility allows the user to check information contained in the USB 
Key that is attached to the computer in use.  With this utility the user can see the following 
information: dongle serial number and expiration date, licensed program names and type 
of licenses, maintenance expiration date of each software license, licensed company name, 
allowed IP subnets.  This utility is installed in the selected installation directory with the 
following filename: ensoft_key_inquirer_v5.exe (may change with time). 

Check Network Dongle .   this selection is only available in client computers of local network licenses (not 
available in single-user licenses).  This calls the utility that is used to check the licensing 
and to troubleshoot communications with a license manager (or software server).  This 
utility is very useful in case of problems in clients while trying to run the licensed software.  
This utility is installed in the selected installation directory with the following filename: 
CheckNetworkDongle_ipv_512.exe (may change with time). 
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3.1 File Menu 
This menu contains selections related to the management of input-data files and to exit the program.  Input-
data files created for SHAFT are provided with a standard file-name extension in the form of 
*filename*.sf9d (where *filename* represents any Windows-allowable file name).  All input data files are 
standard text files and may be edited with any text editor or word-processing program. 

3.1.1 File > New 

  Once the program is started, default values are used for certain operating parameters and a blank 
input-data file is created.  Selecting New under the File menu resets all SHAFT variables to either default 
or blank values, as appropriate.  This option should be selected when a new data file is desired to be created 
from a blank form.  This menu option may also be accessed with the Ctrl+N keyboard combination. 

3.1.2 File > Open 

  This is used to open a file that has been previously prepared and saved to disk. The File > Open 
window dialog, shown in Figure 3.1, is used to search for an existing input-data file.  By default, the file is 
initially searched in the directory where SHAFT was installed.  After initial usage the program will default 
to the last directory where a data file has been successfully opened.  Standard windows-navigation 
procedures may be used to locate the name and directory of the desired project file.  This menu option may 
be accessed with the Ctrl+O keyboard combination.  

Every analytical run of SHAFT produces several additional files (previously described in Table 2.1 of this 
manual).  The name of the input-data file indicates the names of all related files produced by a successful 
program run (output, graphics, and processor text files).  All the additional program files will be created in 
the same directory as the input file.  Input-data files that are partially completed may be saved and later 
opened for completion, run, and observation of results. 

Opening partially-completed SHAFT input files or invalid data files may produce an information window 
reporting that an “invalid or incomplete” file is being opened.  The user should click the OK button and all 
partial-input data that was previously prepared should become available. 

The program allows users to read input-data files created for the previous SHAFT 2012 or 6.0 versions by 
selecting the drop-down arrow at the bottom right corner of the File > Open dialog window (Figure 3.1).  
The program will automatically convert the opened SHAFT 2012 or 6.0 input files to the latest version of 
SHAFT when the user saves the file. 
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Figure 3.1  File > Open Dialog Screen 

3.1.3 File > Save 

This selection is used to save input data under the current file name.  With this method of storing 
data to disk, any input data that was previously saved with the same file name is replaced with the current 
parameters.  Input-data files should be saved every time before proceeding with runs for analytical 
computation.  This menu option may also be accessed with the Ctrl+S keyboard combination. 

3.1.4 File > Save As 

This selection allows the user to save any opened or new input data file under a different file name and/or 
different directory.  Any input data file saved under an existing file name will replace the contents of the 
existing file. 

3.1.5 File > Exit 

This is selected to exit SHAFT.  Any input-data file that was modified and not yet saved to disk will produce 
a confirmation window before exiting the program (see Figure 3.2). 
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Figure 3.2   Message window advising that changes were not saved to disk 

3.2 Data Menu 
The input of specific parameters for an application is controlled under selections contained within this menu 
(shown in Figure 3.3).  It is recommended that the user choose each submenu and enter parameters in a 
consecutive manner starting from the top of this menu. 

Selecting or clicking any of the submenu choices contained in the Data menu produces various types of 
windows.  As a reminder of standard commands of Microsoft Windows®, open windows may be closed by 
all or some of the following methods: 

• clicking the OK button (if available),or 
• clicking the X-box on the upper-right corner of the window, or 

• double-clicking the SHAFT icon on the upper-left corner of the window, or 

• clicking once on the SHAFT icon on the upper-left corner of the window and then choosing 
Close. 

Open windows may optionally be left open on the screen.  The selection of other menu options will then 
produce new windows on top of those that were left open. 

Many sub-windows of the Data menu will show an Add Row, Insert Row and/or Delete Row buttons.  
The Add Row button always adds new rows at the end after all existing rows.  The Insert Row button 
always inserts a new row right after an existing row highlighted by the mouse.  Clicking on the Delete 
Row button deletes the row where the cursor is located. 
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Figure 3.3   Data Menu 

3.2.1 Numeric Data Entries 

Cells that require numeric data may accept entries of mathematical expressions in addition to simple 
numeric entries.  Entering a mathematical expression works similarly to normal numeric data.  The user 
types the expression that represents the data and presses the Return key to calculate the entered expression 
and to display the numeric result in the same cell. 

Table 3.1 below shows the list of supported operations and constants.  The order of operations follows the 
order in the list of Table 3.1.  Note that implicit multiplication (i.e. 2(4+6)) is not supported (instead, use 
2*(4+6) for the previous example). 
 

 OPERATORS  
Symbol  Description  

()  Parenthesis (may be nested)  
^  Exponentiation  
*  Multiplication  
/  Division  
+  Addition  
- Subtraction  
- Negation (same as subtraction)  
  
 CONSTANTS  

Symbol  Value  
PI (or pi)  3.1415927  
e (or E)  2.7182818  

Table 3.1   Supported mathematical operations and constants 

The two constants that are currently supported are PI and e.  Implicit multiplications using constants is not 
supported (use 2*e instead of 2e).  Negation of the constants PI or e is not allowed.  For instance, instead 
of entering -PI the user must enter - (PI). 
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Scientific notation (i.e. 1.65e8 or 1.65e-8) may be used to input very large or very small numbers.  After an 
expression is calculated, very large or very small numbers will be displayed using scientific notation. 

3.2.2 Data > Units 

This selection provides the user with a choice of specifying input data in English Units, and S.I. Units 
(international units).  In general, the following specific units of measurements will be used throughout the 
program: 
Units   Length   Force   Modulus 
English   foot (ft)    pounds (lbs)  psi 
International   meters (m),   kilo Newtons (kN) kPa 

The user should always check the unit specification, which is affixed to each variable, for data input.  For 
instance, psi instead of psf is used for the elastic modulus of materials. 

The user may change from one system of units to the other as many times as desired.  The program will 
automatically convert all the appropriate input that was already specified by the user before the time of 
selection of a different system of units.  Small conversion errors may appear if multiple changes of units 
are performed.  The user must always check that input data have been converted appropriately. 

3.2.3 Data > Design Method (ASD or LRFD) 

This submenu option allows the user to select either the Allowable Stress Design (ASD) method or the 
Load and Resistance Factor Design (LRFD) method as shown in Figure 3.4.  In the United States, many 
engineers use a combination of the ASD method for geotechnical analysis of the foundation and the LRFD 
method for analysis of the foundation as a structural member. 

The ASD method is also known as the factor of safety method.  The ASD method is most often used by 
foundation engineers and is usually referenced as the global approach.  The engineer will consider all of 
the factors at hand, including such things as the quality of the subsurface investigation, the statistical nature 
of the loading, and the expected competence of the contractor, and an overall factor of safety is selected for 
individual piles and for the group of piles. 

The LRFD method originated in structural engineering and is usually termed as the component approach.  
The LRFD method was accepted formally in 1994 by the American Association of State Highway and 
Transportation Officials (AASHTO) as a standard. 
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Figure 3.4   Data Menu > Design Method (ASD or LRFD) 

3.2.4 Data > Title 

 This selection activates the window shown in Figure 3.5, where the user can enter a line of text 
containing a general description for the application problem.  Any combination of characters may be entered 
in the text box in order to describe a particular application.  The user input will be restrained automatically 
once the maximum length of text is reached.  This is done to prevent the user from going beyond the 
maximum permissible length of characters allowed for the title line. 
 

 
Figure 3.5   Sample Data > Title 

3.2.5 Data > Drilled-Shaft Properties 

  In this menu, shown in Figure 3.6,  the user is provided with the option to select either a 
Drilled Shaft (also known as ‘bored pile’ or ‘augered cast in place pile’) or a CFA Pile (also known as 
‘continuous flight auger’ pile).  Depending on the user’s selection, the program will display the screens 
shown in Figure 3.7 (Drilled-Shaft Properties) or Figure 3.8 (CFA Pile Properties). 
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Figure 3.6   Data Menu > Drilled-Shaft/CFA Pile Properties 

 
Figure 3.7   Sample Drilled-Shaft Properties 
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Figure 3.8   Sample CFA Pile Properties 

The various input parameters that are needed under entries in the Data > Drilled-Shaft/CFA Pile 
Properties menu option are listed below. 

Minimum Shaft Diameter 

This is the minimum (or initial) diameter to be considered in the computations.  The English unit for this 
variable is “ft”, while “meter” is for the SI unit. 

Maximum Shaft Diameter 

This is the largest diameter to be considered in the computations.  The English unit for this variable is “ft”, 
while “meter” is for the SI unit. 

The program will compute the axial capacity of drilled shafts starting with the minimum diameter and then 
add 0.5 ft (0.15 m) to the diameter for each consecutive run until the diameter reaches the largest 
(maximum) specified.  This default increment of diameter can be changed in Data > ASD/LRFD Design 
Charts for models that use such analytical method. 

If the user only wants to run with the initial diameter, the variable for the largest diameter should be left as 
zero (or same as the minimum diameter). 
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In models where there is one or more layers of rock along with defined Minimum and Maximum shaft 
diameters the program will use the defined ratio of (rock socket diameter/shaft diameter) for all analyzed 
cases of increased shaft diameter (up to the Maximum defined). 

Ratio of Base Diameter to Shaft Diameter 

To define a belled shaft the user should enter the ratio of the base diameter to the stem diameter.  The 
program will calculate the dimension of the bell accordingly.  For a straight shaft, the value for this variable 
should be left as zero. 

Belled shafts are not used in cohesionless soils (sand, gravel) or rock. 

For belled shafts in uplift, the program computes side resistance of a column with a diameter equal to that 
at the base of the bell (Bb). 

Angle of Bell with Respect to Vertical 

For a belled shaft, the user should enter the angle (in degrees) from the vertical line to the slope of the bell 
(always smaller than 90 degrees).  The program will calculate the dimension of the bell accordingly.  For a 
straight shaft, the value for this variable should be left as zero. 

Belled shafts are not used in cohesionless soils (sand, gravel) or rock. 

Length of Upper Exclusion Zone without Skin Friction 

This number (always positive) represents the section length on the top of the shaft that is declared as 
noncontributing to side resistance. 

This upper exclusion zone is not recommended in cohensionless soils. 

The English unit for this variable is “ft” while “meter” is for the SI unit. 

Length of Bottom Portion of Shaft without Skin Friction 

This number (always positive) represents the section length at the bottom of the shaft that is declared 
noncontributing to side resistance.  For a belled shaft, this length is taken above the beginning of the bell. 

This lower exclusion zone is not recommended in cohensionless soils.  For shafts in cohesive soils, this 
lower exclusion zone is not recommended for uplift loading. 

The English unit for this variable is “ft” while “meter” is for the SI unit. 

Modulus of Elasticity of Drilled Shaft 

Modulus of Elasticity of CFG Pile 

This number (always positive) represents the modulus of elasticity of the drilled shaft or CFA pile.  The 
user may enter in this variable the elastic modulus of the composite section or simply use the elastic modulus 
of the concrete.  The English unit for this variable is “psi” while “kPa” is for the SI unit. 
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3.2.6 Data > Soil Layer Data 

 This submenu allows the user to specify the different types of soil/rock and material properties to 
be used for the computations.  Illustrations of the Soil Layer Data window for example applications are 
shown in Figure 3.9 and Figure 3.10. 

A general description for the data needed under each column in the Data > Soil Layer Data submenu 
option is listed below. 

 
Figure 3.9   Sample Data > Soil Layer Data dialog box for ASD Method 

 
Figure 3.10   Sample Data > Soil Layer Data dialog box for LRFD Method 
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Layer 

This column includes Edit Layer x buttons where x is a sequential number that is automatically and 
sequentially provided to each soil layer.  This number is computed by the program as new rows of soil 
layers are added.  The maximum number of soil layers that may be used in a model is limited to 40. 

Clicking on each Edit Layer x button allows the user to specify soil or rock properties that correspond to 
the defined soil layer.  A sub-window will pop on the screen when each Edit Layer x button is selected.  
The program requires different input parameters for each type of soil and rock.  Therefore, the data column 
in the sub-window that appears varies with the selection made by the user in the Soil Type drop-down list.  
A detailed description of the parameters needed for each soil and rock type is described in Section 3.2.7. 

Soil Type 

This column includes drop-down buttons that are used to select the type of each soil layer.  There are 
currently nine internal types of soils that may be specified for program SHAFT.  The user specifies the 
desired soil type using a drop-down list with the following choices: 
 Code Number Internal Soil Type 
 1 Sand (FHWA) 
 2 Clay (FHWA) 
 3 Shale (Aurora and Reese) 
 4 Strong Rock (FHWA, qu > 1000 psi, either Side Friction or Tip Resist.) 
 5 Decomposed Rock/Gravel (FHWA) 
 6 Weak Rock (FHWA) 
 7 Strong Rock (Side Friction + Tip Resistance) 
 8 Gravelly Sand (Rollins et al) 
 9 Gravel (Rollins et al) 

In  models using the new CFA Piles, the recommended criteria is limited to the following two soil types: 
 Code Number Internal Soil Type 
 10 Sand (for CFA Piles) 
 11 Clay (for CFA Piles) 

For strong rock, FHWA recommends to use either side friction or tip resistance but not both, as described 
in the Technical Manual.  However, in some cases the user may want to observe the shaft capacity that 
includes the side friction and tip resistance together.  Such evaluation may be done by selecting Soil Type 
7.  The user must consider good engineering judgment when selecting such option. 

Depth at Bottom of Each Layer 

Values for the bottom of each soil layer are entered with respect to an origin of coordinates set at the ground 
surface.  As a minimum, the bottom of the last soil layer must be two pile diameters deeper than the depth 
of the modeled shaft. 

Max. Side Friction 

In this entry the user may specify the maximum value of skin-friction transfer that is permissible for a given 
stratum.  If the user enters a value for the maximum-permissible skin friction, the program will compare its 
internally-computed value with the maximum provided and the program will use the smaller of these two 
for the final computation.  If the user does not want to add any restriction on the computed value, simply 
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enter 0 to suppress this option and always use the internally-computed values.  A very small value (eg. 
0.001 psf) may be entered if the user wants to ignore any load transfer in side friction for the selected layer. 

Max. End Bearing 

In this entry the user may specify the maximum value of transfer in end bearing that is permissible for a 
given stratum.  If the user enters a value for the maximum-permissible end bearing, the program will 
compare the internally-computed value with the maximum provided and the program will use the smaller 
of these two for the final computation.  If the user does not want to add any restriction on the computed 
value, simply enter 0 to suppress this option and always use the internally-computed values.  A very small 
value (eg. 0.001 psf) may be entered if the user wants to ignore any load transfer in end bearing for the 
selected layer. 

LRFD Resistance Factor (Side Friction) 

If the user selects the LRFD design method, a data column for entering the LRFD resistance factor on side 
friction is added onto the input table as shown in Figure 3.10.  In this entry the user may specify the 
resistance factor on skin-friction transfer that is permissible for a given stratum.  Enter 1.0 for no reductions 
on the computed values of side friction. 

LRFD Resistance Factor (End Bearing) 

If the user selects the LRFD design method, a data column for entering the LRFD resistance factor on tip 
resistance is added onto the input table as shown in Figure 3.10.  In this entry the user may specify the 
resistance factor on the tip resistance that is permissible for a given stratum.  Enter 1.0 for no reductions on 
the computed values of end bearing. 

3.2.7 Data > Soil Layer Data > Edit Layer x 

As mentioned earlier, the Edit Layer x button allows the user to define soil and/or rock properties for the 
selected strata.  A new dialog box is provided when the Edit Layer x button is clicked.  The program 
requires different input parameters for each type of soil and rock.  Required entries vary according to the 
selection that is made by the user in the Soil Type drop-down list. 

In general, the Edit Layer x provides entry fields for the top of the layer and the bottom of the layer.  The 
user may enter different parameters for the top and the bottom of each layer.  The program will interpolate 
linearly the data for any point between those two depths.  The following sections provide a general 
description regarding input data for each soil type. 

After each successful model run, users are encouraged to double check their entries and the calculated 
values in the output text (Computation > View Output Text). 

3.2.7.1 Sand Layers 

A sample dialog screen for Sand (FHWA) layers is shown in Figure 3.11. The inputs for sand layers are 
explained below. 

Side Friction Procedure 
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Three computational methods are offered for load transfers in side resistance on cohesionless soils.  The 
selection of a method changes the required input below to display only information that is applicable to the 
selected method. 

Ko Method  .... this is also known as “the fundamental method,” and was presented by Kulhawy (1991), 
Mayne and Harris (1993), Chen and Kulhawy (2002), Kulhawy and Chen (2007), and 
evaluates separately the values of K and δ which are then combined to determine β. 

Beta Method  .. this is also known as the “depth-dependent β method” and this is the basis of the equations 
given in the first version of the FHWA Drilled Shaft Manual (O’Neill and Reese, 1999) as 
well as the AASHTO LRFD Bridge Design Specifications (2007).  This method requires 
the input of the Beta Value which is described further below. 

Chen and Kulhawy (FHWA, GEC 10) Method  This is basically the Ko Method described earlier 
but with the ability to define the parameter m (the exponent for computation of 
preconsolidation stress).  See more information about this method in the Technical Manual 
and further below while describing the Preconsolidation Stress Exponent (m). 

 

Figure 3.11   Sample soil data for sand (FHWA) layers 
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Total Unit Weight 

This column entry corresponds to values of total unit weight (submerged weight is calculated based on the 
separate Data > Water Table entry for depth of water table).  Values for the top and bottom of the sand 
layer are entered in standard units of force per unit volume (either lb/ft3 or kN/m3).  The SHAFT program 
will interpolate linearly between the values provided for the top and the bottom of each layer. 

Ko (Coefficient of Lateral Earth Pressure) 

This is only enabled in models where the user selects Ko Method for Side Friction Procedure as defined 
at the beginning of this section. 

This input reflects values of the lateral earth pressure coefficient for the top and bottom of the sand layer.  
Values for Ko depend on the relative density of the sand and the process by which the sand deposits were 
formed.  For general reference, if the sand deposits did not receive any artificial compaction, values of Ko 
range from about 0.40 for loose to 0.50 for dense sand.  Artificial compaction or tamping may increase Ko 
values to 0.80.  The SHAFT program will interpolate linearly between the values provided for the top and 
the bottom of each layer. 

Beta Value 

This is only enabled in models where the user selects Beta Method for Side Friction Procedure as defined 
at the beginning of this section. 

The Beta Value is an empirical parameter that takes into account the lateral earth pressure coefficient and 
the effective-friction angle at the interface between the concrete of the shaft and the soil.  The parameter 
thus takes into account the fact that the stress at the interface due to the fluid pressure of the concrete may 
be greater than that from the soil itself.  Many factors that modify the lateral stress at the soil-concrete 
interface can be taken into account with the Beta value.  For instance, factors may include the use of drilling 
fluid, use of casing or a dry excavation during the construction process, and the type of slump used in the 
concrete. 

If the input for Beta is left as zero, the computer program automatically generates Beta values at each foot 
of penetration in the sand layer (or at each 0.3 meters if SI units are used).  Internally, the SHAFT program 
uses the method specified in the FHWA Drilled Shaft Manual (O’Neill and Reese, 1999) as well as the 
current AASHTO LRFD Bridge Design Specifications (2007) 

This method (O’Neill and Reese, 1999) is covered in the Technical Manual of this product.  The method 
uses a formula that assumes a drilled shaft construction with a concrete slump of 6 in. or higher.  The 
method also assumes that drilling slurry, if employed, should be such that it would not cause a weak layer 
of bentonite to develop at the wall of the excavation.  The following formula is used internally to compute 
Beta values: 

 For N > 15... β = 1.5 - 0.135 z0.5 

 For N < 15... β = (N/15) (1.5 - 0.135 z0.5) 

Where 
β = empirical value, limited to 1.2 > β > 0.25 
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z = depth belowground surface, in units of ft. 
N = uncorrected blow counts from the SPT test. 

Optionally the user may input his own value of Beta for the top and bottom of the layer.  The SHAFT 
program will interpolate linearly between the values provided for the top and the bottom of each layer. 

Preconsolidation Stress Exponent (m) 

This is only enabled in models where the user selects Chen and Kulhawy Method for Side Friction 
Procedure as defined at the beginning of this section.  This is basically the Ko Method described earlier 
but with the ability to define the parameter m (the exponent for computation of preconsolidation stress) in 
the following equation: 

𝑲𝑲𝒐𝒐 = (𝟏𝟏 − 𝒔𝒔𝒔𝒔𝒔𝒔∅′) 𝑶𝑶𝑶𝑶𝑶𝑶𝒔𝒔𝒔𝒔𝒔𝒔∅′ ≤ 𝑲𝑲𝒑𝒑 

  (3.1) 

𝑶𝑶𝑶𝑶𝑶𝑶 =  
𝝈𝝈′𝒑𝒑
𝝈𝝈′𝒗𝒗

 

  (3.2) 

𝝈𝝈′𝒑𝒑
𝑷𝑷𝒂𝒂

≈ 𝟎𝟎.𝟒𝟒𝟒𝟒(𝑵𝑵𝟔𝟔𝟔𝟔)𝒎𝒎 

  (3.3) 

where  

σ'p = effective vertical preconsolidation stress.  Ko is limited to an upper bound value equal to the 
Rankine coefficient of passive earth pressure, Kp.  A variety of methods have been 

proposed for evaluation of either Ko or σ'p by correlations with in-situ test measurements. 

Pa = atmospheric pressure in the same units as σ'p (for example, 2,116 psf).   

The value of m is usually 0.6 for clean quartzitic sands and 0.8 for silty sands to sandy silts.  The user may 
input different values of m for the top and bottom of the layer.  The SHAFT program will interpolate 
linearly between the values provided for the top and the bottom of each layer. 

If the Preconsolidation Stress Exponent (m) and the OCR Value are missing (left as zero), the SHAFT 
program will assume that OCR = 1 in Equation (3.1). 

If the Preconsolidation Stress Exponent (m) is missing (left as zero) but the user enters the OCR Value 
(must be equal or higher than one), the SHAFT program will use the user-specified OCR Value in Equation 
(3.1). 

Blow Counts from SPT 

This column entry corresponds to the number of blow counts obtained at the top and bottom of the sand 
layer while performing a Standard Penetration Test (SPT test).  The user may optionally input Blow Counts 
obtained from SPT tests in cases where the values of Friction Angle and Ko are not readily available.  
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When the user provides a value different than zero for Friction Angle and Ko, the values for Blow Counts 
are not used in the computations and may be left as zero. 

For friction transfers (transfers in side resistance) when Friction Angle is left as zero the computer program 
converts internally between the provided values of Blow Counts from SPT tests to equivalent values of 
Friction Angle using Table 3.2 (for further reference see the Technical Manual for comments of side 
resistance in sand layers). 

For transfers in end bearing, when a Friction Angle is provided (different than zero) the computer program 
uses the Quiros and Reese (1977) recommendations for loose sand, medium-dense sand and very dense 
sand based on ranges of φ angles (for further reference see the Technical Manual for comments of end 
bearing in sand layers). 

When the user provides values of Blow Counts (different than zero) the computer program uses those for 
computations of end bearing following equations and limits specified in the Technical Manual (comments 
of end bearing in sand layers). 

OCR Value 

This is only enabled in models where the user selects Chen and Kulhawy Method for Side Friction 
Procedure as defined at the beginning of this section. 

This entry defines the value for Overconsolidation Ratio (OCR) that will be used for Equation (3.1): 
• If the user has entries (different than zero) for both, Preconsolidation Stress Exponent (m) 

and Blow Counts from SPT, SHAFT will estimate the OCR Value based on Equations (3.2) 
and (3.3). 

• If the Preconsolidation Stress Exponent (m) and the OCR Value are missing (left as zero), 
the SHAFT program will assume that OCR = 1 in Equation (3.1). 

• If the Preconsolidation Stress Exponent (m) is missing (left as zero) but the user enters the 
OCR Value (must be equal or higher than one), the SHAFT program will use the user-
specified OCR Value in Equation (3.1). 

• Any entry for OCR Value smaller than one will be ignored and replaced with OCR = 1. 

Friction Angle 

This column entry corresponds to values of the internal angle of friction (also known as friction or φ angle) 
for the top and bottom of the sand layer.  The values of Friction Angle are entered in standard units of 
degrees. 

For the Ko Method: 

• If both Friction Angle and Blow Counts are defined by the user then the program will use the 
inputted Friction Angle for estimation of transfers in side resistance and the program will use 
the inputted Blow Counts for estimation of transfers in end bearing. 

• If the user only enters Blow Counts (Friction Angle left as zero) then the program will 
estimate the Friction Angle based on Blow Counts (see Table 3.2) to estimate transfers in side 
resistance and will use the inputted Blow Counts for estimation of transfers in end bearing.  
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The program will print the computed Friction Angle in the soil properties section on the output 
text file. 

• If the user only enters Friction Angle (Blow Counts left as zero) then the program will use the 
inputted Friction Angle for estimation of transfers in side resistance and the program will also 
use the inputted Friction Angle for estimation of transfers in end bearing. 

• Values for Ko must always be entered (different than zero) for this method.  If the user wants to 
ignore Ko then use a different method or enter a very small value for Ko. 

For the Chen and Kulhawy Method: 
• If both Friction Angle and Blow Counts are defined by the user then the program will use 

both, the inputted Friction Angle and Blow Counts for estimation of transfers in side 
resistance and the program will use the inputted Blow Counts for estimation of transfers in end 
bearing. 

• If the user only enters Blow Counts (Friction Angle left as zero) then the program will 
estimate the Friction Angle based on Blow Counts (see Table 3.2) to estimate transfers in side 
resistance and will use the inputted Blow Counts for estimation of transfers in end bearing.  
The program will print the computed Friction Angle in the soil properties section on the output 
text file. 

• If the user only enters Friction Angle (Blow Counts left as zero) then the program will use the 
inputted Friction Angle for estimation of transfers in side resistance and the program will also 
use the inputted Friction Angle for estimation of transfers in end bearing. 

For the Beta Method: 
• If both Friction Angle and Blow Counts are defined by the user then the program will use the 

inputted Beta Value for estimation of transfers in side resistance and the program will use the 
inputted Blow Counts for estimation of transfers in end bearing. 

• If the user only enters Blow Counts (Friction Angle left as zero) then the program will use the 
inputted Beta Value to estimate transfers in side resistance and will use the inputted Blow 
Counts for estimation of transfers in end bearing. 

• If the user only enters Friction Angle (Blow Counts left as zero) then the program will use the 
inputted Beta Value for estimation of transfers in side resistance and the program will estimate 
the Friction Angle based on Blow Counts (see Table 3.2) for estimation of transfers in end 
bearing. 

• If the Beta Value is missing (left as zero) then the program will estimate the Beta Value 
based on Eq. 3.5 and others (Section 3.1.1) of the SHAFT Technical Manual.  The program will 
print the computed Beta Value in the soil properties section on the output text file. 

According to the FHWA manuals, for concrete cast in place against soil, as in a drilled shaft, the interface 
is assumed to be rough and the interface friction angle (δ or 𝜙𝜙𝑐𝑐) can be equal to the internal friction angle 
of the soil (ie., δ = φ’).  This is how the SHAFT program considers within internal computations with Sand 
layers. 
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Table 3.2   Relationship between N and φ (after Gibbs and Holtz, 1957) 

3.2.7.2 Clay and Shale Layers 

A sample dialog screen for layers of Clay (FHWA) or Shale (Reese & Aurora) is shown in Figure 3.12. 
The required inputs are explained below. 

Method 

Two computational methods are offered for load transfers on cohesive soils.  The selection of a method 
changes the required input below to display only information that is applicable to the selected method. 

FHWA Method  .............. this entry follows equations given in the first version of the FHWA Drilled Shaft 
Manual (O’Neill and Reese, 1999).  This method requires the input of the Alpha Factor 
which is described further below. 

FHWA, GEC 10 Method  ............... this entry follows the criteria added in the Brown et al (2018) GEC-
10 publication for FHWA. 

Total Unit Weight 

This entry corresponds to values of total unit weight (submerged weight is calculated based on separate 
entry for depth of water table).  Values for the top and bottom of the layer are entered in standard units of 
force per unit volume (either lb/ft3 or kN/m3).  The SHAFT program will interpolate linearly between the 
values provided for the top and the bottom of each layer. 
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Cohesion 

These entries are for values of the unconfined-undrained shear strength at the top and bottom of the clay 
layer.  Ordinarily, these values are taken as one half of the compression strength of samples obtained from 
unconsolidated-unconfined triaxial tests. 

The SHAFT program will interpolate linearly between the values provided for the top and the bottom of 
each layer. 

Type of Test 

This entry is only available for the FHWA GEC 10 (Brown et al 2018) method.  It incorporates corrections 
based on the type of laboratory test that was used to obtain the Cohesion value.  It allows for the following 
three types of tests: Consolidated Isotropically Undrained triaxial Compression (CIUC), Unconfined 
Compression (UC) test, and Unconsolidated Undrained (UU) triaxial compression. The CIUC triaxial test 
is listed on top since it is considered more reliable than UC and UU tests.  See Brown et al (2018) for further 
reference. 

Blow Counts from SPT (Optional) 

This entry is only available for the FHWA 1999 (O’Neill & Reese) method.  This column entry corresponds 
to the number of blow counts obtained at the top and bottom of the clay layer from the performance of a 
Standard Penetration Test (SPT test).  The user may optionally input Blow Counts obtained from SPT tests 
in cases where the values of undrained shear strength (Cohesion) are not readily available.  When the user 
provides a value different than zero for the Cohesion, the values for Blow Counts are not used in the 
computations and may be left as zero. 

The option to input values of Blow Counts instead of Cohesion (undrained shear strength) should be 
selected only when it is desirable to make a rough computation of the load-carrying capacity of a drilled 
shaft.  The computer program converts internally between the provided values of blow counts from SPT 
tests to equivalent values of undrained shear strength by using the following equations (specified in the 
Technical Manual): 

 cu = NSPT / 10, for cu in units of tons/ft2. 

 cu = NSPT / 0.1, for cu in units of kPa. 

Where: 
cQ = unconsolidated-undrained shear strength of the clay. 
NSPT= average number of blow counts (blows per foot) from the Standard Penetration Test. 
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Figure 3.12   Sample soil data for clay (FHWA) and shale layers 

Alpha Factor 

This entry is only available for the FHWA 1999 (O’Neill & Reese) method.  This is an empirical factor 
that varies with depth and takes into account the construction procedures of the drilled shaft.  The amount 
of research that has been performed to date is still insufficient to allow for a precise prediction of the Alpha 
Factor as a function of depth. 

If the user leaves the default values of zero, the program will automatically compute values of Alpha Factor 
according to recommendations from literature (O’Neill and Reese, 1999; and O’Neill and Hassan, 1994).  
It is evident, actually, from the results of the load tests of instrumented drilled shafts that α is not a constant, 
but that it varies with the magnitude of undrained shear strength (which usually varies with depth).  The 
SHAFT program follows the FHWA manual, where O’Neill and Reese (1999) recommend the following 
formulations for variations of alpha values 

α =  𝟎𝟎.𝟓𝟓𝟓𝟓   for   𝒄𝒄𝒖𝒖
𝒑𝒑𝒂𝒂
≤ 𝟎𝟎.𝟓𝟓𝟓𝟓 
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(3.4) 

and 

α =  𝟎𝟎.𝟓𝟓𝟓𝟓 − 𝟎𝟎.𝟏𝟏�𝒄𝒄𝒖𝒖
𝒑𝒑𝒂𝒂
−  𝟏𝟏.𝟓𝟓�   for   𝟏𝟏.𝟓𝟓 ≤ 𝒄𝒄𝒖𝒖

𝒑𝒑𝒂𝒂
≤ 𝟐𝟐.𝟓𝟓 

(3.5) 

where 
𝑝𝑝𝑎𝑎 = atmospheric pressure (14.7 psi, 2116 psf or 101.3 kPa). 

In Equation (3.4) the value of α is 0.55 for up to 𝑐𝑐𝑢𝑢 𝑝𝑝𝑎𝑎⁄  = 1.5 (which corresponds to 𝑐𝑐𝑢𝑢 of about 1.5 tsf).  If 
𝑐𝑐𝑢𝑢 is very low, it is possible that α may be greater than 0.55, but higher values should not be taken unless 
proven by load test.  From 𝑐𝑐𝑢𝑢 𝑝𝑝𝑎𝑎⁄  = 1.5 the values of α reduces linearly to 0.4 when 𝑐𝑐𝑢𝑢 𝑝𝑝𝑎𝑎⁄  = 3.  It is 
considered that a cohesive geomaterial is no longer a cohesive soil when 𝑐𝑐𝑢𝑢 𝑝𝑝𝑎𝑎⁄  exceeds 2.5.  Drilled shafts 
in such geomaterials should be designed according the cohesive intermediate geomaterial (Cohesive IGMs) 
criteria covered in Section 3.2.7.4.  However, data from load tests on hard clays and weak clay shales in the 
South and Southwest of the United States have indicated that α remains at about 0.40 in such geomaterials 
up to 𝑐𝑐𝑢𝑢 𝑝𝑝𝑎𝑎⁄  = 5.  The cohesive soil method can be used in such geomaterials if the α factors are confirmed 
by load tests.  Evidence has shown that values of α are the same for loadings in compression or tension.  
For further reference see the Technical Manual for comments of side resistance in clay layers. 

The values suggested for α  in Equations (3.4) and (3.5) that are internally computed by the SHAFT 
program are by no means certain and mainly correspond to undrained loading of drilled shafts in cohesive 
soil.  The user should input his own values of Alpha Factor if site-specific data is available from loading 
tests.  It is obvious that better estimates of values can be obtained from loading tests on drilled shafts that 
are constructed in situ with the same techniques and procedures that are planned for the production shafts. 

Bearing Capacity Coefficient, Nc 

This column corresponds to the value of bearing capacity coefficient to be used in the computations of end 
bearing for clay.  A value of 7.0 is suggested for the bearing capacity factor, Nc, for shafts built by the 
slurry-displacement method.  This value can be increased to 8.0 when shafts are constructed by the casing 
or in the dry method.  The SHAFT program will interpolate linearly between the values provided for the 
top and the bottom of each layer. 

3.2.7.3 Strong Rock 

A sample dialog screen for layers of Strong Rock (FHWA) is shown in Figure 3.13. The required inputs 
are explained below. 

Total Unit Weight 

This entry corresponds to values of total unit weight (submerged weight is calculated based on separate 
entry for depth of water table).  Values for the top and bottom of the layer are entered in standard units of 
force per unit volume (either lb/ft3 or kN/m3).  The SHAFT program will interpolate linearly between the 
values provided for the top and the bottom of each layer. 

Rock Compressive Strength 
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This column corresponds to the values of uniaxial compressive strength of rock as taken from core samples 
(not intact or mass).  The strong rock criterion requires that the unconfined compressive strength of rock is 
at least 144,000 psf (6,900 kPa).  The SHAFT program takes into consideration the smaller value between 
the compressive strengths of concrete and rock to compute the capacity in side resistance.  Values are 
entered in units of stress (force per unit area, either lb/ft2 or kPa=kN/m2). 

Concrete Compressive Strength 

This column corresponds to the values of unconfined compressive strength (cylinder test) of concrete.  The 
program takes into consideration the smaller value between the compressive strengths of concrete and rock 
to compute the capacity in side resistance.  Values are entered in units of force per unit area (either lb/ft2 or 
kPa = kN/m2). 

Discontinuity Spacing 

The spacing of discontinuities is taken into account to compute the bearing capacity of the rock.  The 
formula is valid for a rock mass with spacing of discontinuities larger than 12 in. (305 mm).  Engineering 
judgment is required for shorter spacing.  Values are entered in units of length (either ft or m). 

Discontinuity Thickness 

The thickness of discontinuities is taken into account to compute the bearing capacity of the rock.  The 
formula is valid for a rock mass with thickness of discontinuities smaller than 0.2 in. (5 mm).  Engineering 
judgment is required for larger thickness.  Values are entered in units of length (either ft or m). 

Socket Diameter 

The diameter of the rock socket is taken into account to compute the bearing capacity of the rock.  Values 
are entered in units of length (either ft or m). 

In models where there is one or more layers of rock along with defined Minimum and Maximum shaft 
diameters (under Data > Drilled-Shaft Properties) the program will use the defined ratio of (Socket 
Diameter/Shaft Diameter) for all analyzed cases of increased shaft diameter (up to the Maximum defined). 
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Figure 3.13   Sample soil data for layers of strong rock 

Elastic Modulus 

This column corresponds to the value of Young’s modulus of the intact rock.  The computer program 
internally modifies the value of the elastic modulus of the intact rock according to the RQD values that are 
placed in the last input data for strong rock.  The objective is to obtain values for the modulus of the in-situ 
rock that take into account the number of joints and their spacing.  If values of the modulus of elasticity for 
the rock are available from in-situ tests, the test values should be used along with an input of 100 in the 
RQD column (to avoid modifications of the in-situ rock modulus).  Values are entered in standard units of 
force per unit area (either lb/ft2 or kPa=kN/m2). 

RQD 

This column corresponds to the values of “rock quality designation” or RQD obtained from in-situ soil 
tests.  According to the RQD value, the modulus of the intact rock is modified to account for joints in the 
rock.  The adjustments are performed internally by the computer program using formulations in the 
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Technical Manual.  Please read previous entry for Elastic Modulus for other information regarding entries 
of RQD. 

3.2.7.4 Decomposed Rock/Gravel Layers 

A sample dialog screen for layers of Decomposed Rock/Gravel (FHWA) is shown in Figure 3.14. The 
required inputs are explained below. 

Total Unit Weight 

This column entry corresponds to values of total unit weight (submerged weight is calculated based on 
separate entry for depth of water table).  Values for the top and bottom of the layer are entered in standard 
units of force per unit volume (either lb/ft3 or kN/m3). 

Blow Counts from SPT 

This column entry corresponds to the number of blow counts obtained at the top and bottom of the layer 
while performing a Standard Penetration Test (SPT test).  The user should preferably input the value of 
N60, which is the SPT blow counts, in blows per foot (or blows per 300 mm) for the condition in which the 
energy transferred to the top of the drive string is 60% of the drop energy of the SPT hammer. 

Poisson’s Ratio 

The Poisson ratio of the decomposed rock (gravel or decomposed geomaterial) at the top and bottom of the 
layer.  This value can be approximated as 0.3 to 0.4 for drained loading in gravel, unless more specific 
values are available for the site.  This value is only used in the computations of load versus settlement for 
this type of soil/rock criteria. 
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Figure 3.14   Sample soil data for decomposed rock/gravel layers 

Young’s Modulus (Optional) 

This column represents Young’s modulus of elasticity of the material at the top and at the bottom of the 
socket in the gravel/decomposed rock layer.  These values are only used in the computations of load versus 
settlement for this type of soil.  If the user leaves the default values of zero for Young’s Modulus, the 
program will automatically compute values at the top and bottom of the gravel layer based on the values of 
Blow Counts inputted earlier.  The program computes the modulus of elasticity of the soil based on 
equations presented in the Technical Manual. 

Socket Diameter 

The diameter of the socket in the gravel/decomposed rock may be specified to be different than at other 
layers.  The values on this column are only used in the computation of load versus settlement.  Values are 
entered in standard units of length (either ft or m).  In models where there is one or more layers of rock 
along with defined Minimum and Maximum shaft diameters the program will use the defined ratio of (rock 
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socket diameter/shaft diameter) for all analyzed cases of increased shaft diameter (up to the Maximum 
defined). 

3.2.7.5 Weak Rock 

A sample dialog screen for layers of Weak Rock (FHWA) is shown in Figure 3.15. The required inputs 
are explained below. 

 
Figure 3.15   Sample soil data for weak rock layers 

Total Unit Weight 

This entry corresponds to values of total unit weight (submerged weight is calculated based on separate 
entry for depth of water table).  Values for the top and bottom of the layer are entered in standard units of 
force per unit volume (either lb/ft3 or kN/m3).  The SHAFT program will interpolate linearly between the 
values provided for the top and the bottom of each layer. 

Interface Condition 
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This column input is related to the condition of the borehole after drilling.  Weak rocks behave quite 
differently if the borehole is either rough or smooth after drilling.  The user must select only one of the four 
available options for the top and bottom of the layer of weak rock: (1) Rough Surface w/closed joints, (2) 
Smooth Surface w/closed joints, (3) Rough Surface w/open joints, or (4) Smooth Surface w/ open joints. 

In general, if the user selects to use a Rough Surface option, one of the following conditions should be 
present: 

• The construction specifications should require that the drilling contractor roughen the borehole 
by cutting circular grooves of approximately 50 mm. (2 in.) height into the sides of the 
borehole.  Each circular groove should penetrate at least 25 mm (1 in.) into the borehole walls 
over the full 360 degrees around the holes.  The circular grooves should have vertical spacing 
no greater than 0.3 m (1 ft). 

• The designer must be otherwise convinced that the drilling will produce a roughness pattern 
generally equivalent to the specification recommended above (circular grooves), without 
leaving any soft, soil-like material (or “smears”) on the wall of the borehole. 

It is recommended to consider a Smooth Surface option if none of the conditions specified earlier can be 
achieved.  In addition, if there is a possibility that the borehole is drilled using a drilling slurry, unless 
circular grooves are cut into the weak rock and verified by callipering, the user should assume a Smooth 
Surface condition. 

Joints are considered closed if they contain no voids or soft material in the joint. Likewise a joint is 
considered open if the joint contains voids or soft material. 

Rock Compressive Strength 

This column corresponds to the values of qu, the uniaxial compressive strength of rock.  Whenever possible, 
the weak rock cores should be consolidated to the mean effective stress in the ground and then subjected to 
undrained loading to establish the value for qu.  The validity of this solution is for soft rocks with 0.5< qu 
< 5.0 MPa (73< qu < 725 psi).  The method also assumes that high-quality samples, such as those obtained 
using triple-walled, core barrels, have been recovered.  Values are entered in standard units of force per 
unit area (either lb/ft2 or kPa = kN/m2). 

Concrete Slump 

This column represents the value for the slump of the concrete that will be used in the weak-rock socket.  
This is provided in units of length (in or m).  The user would normally use the same concrete slump at the 
top and bottom of the layer.  The fluidity of the concrete (as measured by the concrete slump) along with 
the depth of concrete are used as an indication of the pressures that the concrete will exert against the 
borehole walls. 

The internal formulas used in the computer program are only valid for the following conditions: 
• the concrete slump must be between 125 to 225 mm (5 in to 9 in), 

• the rate of placement of concrete in the borehole should exceed 12 m/hour (40 ft per hour, or 
about 8 in. per minute), and 

• the ratio of the maximum size of the coarse aggregate to the borehole diameter should be less 
than 0.02. 
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Interface Friction Angle 

This column represents the value for φrc in degrees.  The parameter φrc, represents the angle of internal 
friction of the weak rock at the interface with the concrete.  A value for φrc that is considered typical of 
most clay-shales and mudstones in the United States is φrc = 30 degrees.  This is a value that was measured 
at a test site in clay-shale. 

Socket Diameter 

This column represents the value for D, the diameter of the rock socket, in units of length (ft or m).  The 
value of socket diameter is used in the computation of settlement.  The SHAFT program thus uses only the 
value specified at the bottom of the layer. 

The computations of settlement are only considered accurate for drilled shafts satisfying the following 
conditions: 

• 2< L/D< 20,where L is the length of the socket in weak rock and D the socket diameter, and 

• D > 0.5 m (or D > 20 in.). 

In models where there is one or more layers of rock along with defined Minimum and Maximum shaft 
diameters the program will use the defined ratio of (rock socket diameter/shaft diameter) for all analyzed 
cases of increased shaft diameter (up to the Maximum defined). 

Elastic Modulus of Rock Core 

This column represents the value for Ei, Young’s elastic modulus of elasticity of intact rock cores at the top 
and bottom of the socket.  The parameter must be provided in units of stress (force per unit area, either lb/ft2 
or kPa=kN/m2). 

RQD 

This column corresponds to the values of “rock quality designation” or RQD obtained from in-situ soil tests 
at the top and bottom of the socket.  Internally, the computer program uses the RQD to modify the modulus 
of elasticity of the rock, Ei, to obtain the mass modulus of elasticity, Em, based on the values of Table 7.1 
in the Technical Manual.  Linear interpolation is used for intermediate values. 

Em can be estimated from the ratios in the referenced table based on the RQD of the weak rock (IGM) 
cores.  In cases in which the RQD of the cores is less than 50 percent, it is advisable to make direct 
measurements of Em in situ through plate loading tests, borehole jack tests, large-scale pressure meter tests, 
or by back-calculating Em from drilled shaft loading tests, since the correlations in the referenced table 
become less accurate with decreasing RQD. 

3.2.7.6 Strong Rock Including Side Friction plus End Bearing 

The same data format described for Strong Rock in Section 3.2.7.3 is applicable to this soil option.  As 
described in the Technical Manual, in strong rock FHWA recommends to use either side friction or tip 
resistance only, but not both.  However, this soil option becomes convenient for cases where the user desires 
to observe the calculated capacity that includes the side friction and tip resistance together.  The user should 
use a good engineering judgment when considering this option. 
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3.2.7.7 Gravelly Sand and Gravel Layers 

A sample window for gravelly sand layers or gravel layers is shown in Figure 3.16.  The required properties 
for these soils are explained below. 

 
Figure 3.16   Sample soil data for gravelly sand and gravel layers 

Total Unit Weight 

This column entry corresponds to values of total unit weight (submerged weight is calculated based on 
separate entry for depth of water table).  Values for the top and bottom of the layer are entered in standard 
units of force per unit volume (either lb/ft3 or kN/m3). 

Blow Counts from SPT 

This column entry corresponds to the number of blow counts obtained at the top and bottom of the layer 
while performing a Standard Penetration Test (SPT test).  It should be noted that the Blow Counts should 
be greater than 25 for usage of either criteria of gravelly sand or gravel (soils with Blow Counts less than 
25 would be modeled better using the Sand criteria).  User-inputted values of Blow Counts are used to 
calculate End Bearing following Table 3.2 in the Technical Manual. 



CHAPTER 3 – References for Data Input – 3-31 
 

User’s Manual (Rel. Apr/2023)  SHAFT v2023 
 

Beta Value (Optional) 

The Beta value is an empirical parameter that takes into account the lateral earth pressure coefficient and 
the effective-friction angle at the interface between the concrete of the shaft and the soil.  The parameter 
thus takes into account the fact that the stress at the interface due to the fluid pressure of the concrete may 
be greater than that from the soil itself.  Many factors that modify the lateral stress at the soil-concrete 
interface can be taken into account with the Beta value.  For instance, other factors may include the use of 
drilling fluid, use of casing or a dry excavation during the construction process, and the type of slump used 
in the concrete. 

If the input for Beta is left as zero, the computer program automatically generates Beta values at each foot 
of penetration in the layer (or at each 0.3 meters if SI units are used).  Internally, the SHAFT program uses 
the equations recommended by Rollins et al (2005) for the Beta value, which is covered in the Technical 
Manual. 

Optionally the user may input his own value of Beta for the top and bottom of the layer.  The SHAFT 
program will interpolate linearly between the values provided for the top and the bottom of each layer. 

3.2.7.8 Sand Layers for CFA Piles 

A sample dialog screen of Sand for CFA Piles is shown in Figure 3.17.  

Three computational methods are offered and the selection of a method changes the required input below 
to display only information that is applicable to the selected method. 

Coleman and Arcement…. this method is a modification of the FHWA (1999) β method for side 
resistance and is based on multiple CFA pile tests analyzed by Coleman and Arcement 
(2002).  It is a recommended alternative for CFA piles in GEC 8 (2007) from FHWA.  End 
bearing is calculated using the FHWA (1999) with SPT values. 

European LPC…. this is a method using results from cone penetrometer tests (CPT) and also a 
recommended alternative for CFA piles in GEC 8 (2007) from FHWA.  It is based on 
publications from Bustamante and Gianeselli (1981, 1982) for the Laboratorie Des Ponts 
et Chausses (LPC). 

FHWA O’Neill & Reese…. this is also known as the “depth-dependent β method” and this is the basis of 
the equations given in the first version of the FHWA Drilled Shaft Manual (O’Neill and 
Reese, 1999) as well as the AASHTO LRFD Bridge Design Specifications (2007).  This 
method requires the input of the Beta Value which is described further below. 
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Figure 3.17   Sample soil data of Sand for CFA Piles 

Total Unit Weight 

This column entry corresponds to values of total unit weight (submerged weight is calculated based on the 
separate Data > Water Table entry for depth of water table).  Values for the top and bottom of the sand 
layer are entered in standard units of force per unit volume (either lb/ft3 or kN/m3).  The SHAFT program 
will interpolate linearly between the values provided for the top and the bottom of each layer. 

Blow Counts from SPT 

This column entry corresponds to the number of blow counts obtained at the top and bottom of the sand 
layer while performing a Standard Penetration Test (SPT test).  Values of Blow Counts are used for 
computations of end bearing following equations and limits specified in the Technical Manual (comments 
of end bearing in sand layers).  This entry is not enabled nor used in the European LPC method. 

Soil Type 
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This entry is only required for the Coleman and Arcement method.  The user can select the use of Sandy 
Soils or Silty Soils to define the characteristics of the load transfer in side resistance for this criteria. 

CPT Qc 

This entry is only required for the European LPC method.  The entry represents the cone bearing 
resistance, qc, obtained from standard penetrometer tests (CPT).  It is entered in standard units of pressure 
(either lb/ft2 or kN/m2).  The method provides a formulation for computations of load transfers in side 
resistance and in end bearing based on this entry for sand layers. 

Beta Value 

This entry is only enabled in the FHWA O’Neill & Reese method.  The reference for this entry was defined 
previously in Section 3.2.7.1 of this manual. 

Friction Angle 

This entry is only enabled in the FHWA O’Neill & Reese method.  This column entry corresponds to 
values of the internal angle of friction (also known as friction or φ angle) for the top and bottom of the sand 
layer.  The values of Friction Angle are entered in standard units of degrees.    The reference for this entry 
was defined previously in Section 3.2.7.1 of this manual. 

3.2.7.9 Clay Layers for CFA Piles 

A sample dialog screen of Clay for CFA Piles is shown in Figure 3.17.  

Three computational methods are offered and the selection of a method changes the required input below 
to display only information that is applicable to the selected method. 

Coleman and Arcement…. this method is a modification of the FHWA (1999) α method for side 
resistance and is based on multiple CFA pile tests analyzed by Coleman and Arcement 
(2002).  It is a recommended alternative for CFA piles in GEC 8 (2007) from FHWA.  End 
bearing is calculated using the FHWA (1999) with Nc values. 

European LPC…. this is a method using results from cone penetrometer tests (CPT) and also a 
recommended alternative for CFA piles in GEC 8 (2007) from FHWA.  It is based on 
publications from Bustamante and Gianeselli (1981, 1982) for the Laboratorie Des Ponts 
et Chausses (LPC). 

FHWA O’Neill & Reese…. this entry follows equations given in the first version of the FHWA Drilled 
Shaft Manual (O’Neill and Reese, 1999) as well as the AASHTO LRFD Bridge Design 
Specifications (2007).  This method requires the input of the Alpha Factor which is 
described further below. 
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Figure 3.18   Sample soil data of Clay for CFA Piles 

Total Unit Weight 

This entry corresponds to values of total unit weight (submerged weight is calculated based on the separate 
Data > Water Table entry for depth of water table).  Values for the top and bottom of the sand layer are 
entered in standard units of force per unit volume (either lb/ft3 or kN/m3).  The SHAFT program will 
interpolate linearly between the values provided for the top and the bottom of each layer. 

Undrained Cohesion 

This is not required for the European LPC method but are necessary input for the other two methods.  
These entries represent values for the unconfined-undrained shear strength at the top and bottom of the clay 
layer.  Ordinarily, these values are taken as one half of the compression strength of samples obtained from 
unconsolidated-unconfined triaxial tests. 

The SHAFT program will interpolate linearly between the values provided for the top and the bottom of 
each layer. 
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Bearing Capacity Coefficient, Nc 

This is not required for the European LPC method but are necessary input for the other two methods.  
These entries are for values of bearing capacity coefficient to be used in the computations of end bearing 
for clay.   

Values for the bearing capacity factor, Nc, can be correlated to undrained cohesion (cu) and undrained 
Young’s modulus (Es) for the soil just below the pile tip (O’Neill & Reese, FHWA, 1999).  For ease of 
reference, some suggested relationships are provided in Table 3.3 below (O’Neill & Reese, FHWA, 1999).  
Check relevant sections in Chapter 9 of the SHAFT Technical Manual for further reference. 

 

Undrained 
Cohesion 

Cu 

Rigidity Index 
Ir 

Bearing 
Coefficient 

Nc 

25 kPa 
(520 psf) 50 6.5 

50 kPa 
(1050 psf) 150 8.0 

100 kPa 
(2100 psf) 250 8.7 

200 kPa 
(4200 psf) 300 8.9 

>200 kPa 
(>4200 psf)  9 

>250 kPa 
(>5200 psf)  Use different 

criteria (IGM) 

Table 3.3   Relationships for Cohesive Soils for FHWA 1999 Method 

CPT Qc 

This entry is only required for the European LPC method.  The entry represents the cone bearing 
resistance, qc, obtained from standard penetrometer tests (CPT).  It is entered in standard units of pressure 
(either lb/ft2 or kN/m2).  The European LPC method provides a formulation for computations of load 
transfers in side resistance and in end bearing based on this entry for sand layers. 

Blow Counts from SPT (Optional) 

This entry is only available for the FHWA O’Neill & Reese method.  SPT is not recommended in cohesive 
soils so these entries should only be used as approximation when Undrained Cohesion is not available.  
The reference for this entry was defined previously in Section 3.2.7.1 of this manual. 

Alpha Factor 

This entry is only enabled in the FHWA O’Neill & Reese method.  This is an empirical factor that varies 
with depth and takes into account the construction procedures of the CFA pile.  The reference for this entry 
was defined previously in Section 3.2.7.1 of this manual. 
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3.2.8 Data > Factor of Safety (Allowable Stress Design) 

This is only enabled in models where the user selects Data > Design Method > ASD (Allowable Stress 
Design). 

This submenu allows the user to specify the factor of safety that will be used during internal computations 
(Figure 3.19) for the ASD method.  The user may enter a global factor of safety for the total ultimate 
capacity, or merely apply a factor of safety to the ultimate tip resistance.  Despite the factor of safety that 
is specified by the user, the computer program will provide full printouts of the unfactored ultimate skin 
friction and ultimate tip resistance for reference. 

 
Figure 3.19   Sample screen of Data > Factor of Safety (ASD Method) 

3.2.9 Data > Computation Methods 

The user has the option to run the analysis by specifying either a desired depth or design load.  As shown 
in Figure 3.20, the Computation Methods under the Data menu provides the user the following options: 

• Specify the shaft length 
• Specify the design load 

 

 
Figure 3.20   Data > Computation Methods Menu 

If the user selects to Specify the shaft length, the dialog box in Figure 3.21 will appear for the user to 
enter the proposed shaft length.  Similarly, if the user selects to specify the design load, the dialog box in 
Figure 3.22 will appear for the user to enter the proposed design load. 
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In both cases, as seen in Figure 3.21 and Figure 3.22, the user should also specify the Type of Loading by 
selecting one of the following options: 

• Compression.  When the loads are in compression, the SHAFT program ads the contributions 
from side friction and end bearing.  Please notice that the weight of the shaft is not taken into 
account during computations of pile capacity for compressive loads. 

• Uplift.  For loads in tension, the program takes into account the contributions from side friction 
and weight of the shaft.  The user may also reduce the side-friction contribution to uplift loads 
by specifying a reduction factor smaller than 1. 

The depth specified for the bottom layer must be at least two diameters deeper than the specified-shaft 
length.  The program uses the averaged-soil properties within two diameter below the shaft tip for 
computations of end bearing.  In general, users are recommended to specify the shaft length. 

The program uses 150 lb/ft3 to compute the concrete weight in tension.  In most cases, the weight of concrete 
is ignored in compression due to the small differences that exist between the weight of the displaced soil 
and the concrete. 

 
Figure 3.21   Sample entries under Data > Computation Methods > Specify the shaft 

length 

 

Figure 3.22   Sample entries under Data > Computation Methods > Specify the design 
load 
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3.2.10 Data > Water Table 

This submenu, shown in Figure 3.23, allows the user to specify the depth of the water table.  If this entry is 
left at the default value of zero then the SHAFT program will consider that the water table is located at the 
ground surface.  The water-table depth is referenced from the ground surface. 

 

 
Figure 3.23   Data > Water Table Dialog Screen 
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3.2.11 Data > Evaluate Multiple Shaft Lengths 

This optional selection is used to calculate the axial response of multiple shaft penetrations (lengths).  The 
user can enter any Maximum shaft length but the program will stop at approximately 2.5 pile diameters 
above the depth of the bottom soil layer. The Minimum shaft length can be left as zero and the program 
will default to a minimum length that is 70% of the maximum.  The minimum length must also be at least 
6 pile diameters plus any exclusion zones entered in the model.  The Shaft length increment may also be 
left as zero so the program will use the default of 3 ft (or 1 m). 

This selection is not available in models where the user chooses the separate option of Data > ASD/LRFD 
Design Charts.  A sample of this dialog box is shown in Figure 3.24. 

 
Figure 3.24   Dialog box for Data > Evaluate Multiple Shaft Lengths 

3.2.12 Data > ASD/LRFD Design Charts 

This optional selection is used to calculate and display curves of axial capacity versus depth for user-
specified pile-head settlements.  These curves are similar to the Chart 2 specified in guidelines prepared by 
the Intermodal Transportation Division, Arizona Department of Transportation (ADOT) on December 1, 
2010.  This selection is not available in models where the user chooses the separate option of Data > 
ASD/LRFD Design Charts.  A sample of this dialog box is shown in Figure 3.24. 

The user may enter any Maximum shaft length but the program will stop at approximately 2.5 pile 
diameters above the depth of the bottom soil layer. The Minimum shaft length can be left as zero and the 
program will default to a minimum length that is 70% of the specified maximum.  The minimum length 
must be at least 6 pile diameters plus any exclusion zones entered in the model.  The Shaft length 
increment may also be left as zero so the program will use the default of 3 ft (or 1 m).  The Defined 
Settlements are specified by the user as needed for the top of shaft and entered in units of in or mm. 



CHAPTER 3 – References for Data Input – 3-40 
 

User’s Manual (Rel. Apr/2023)  SHAFT v2023 
 

 
Figure 3.25   Dialog box for Data > ASD/LRFD Design Charts 

3.2.13 Data > Control Options... 

The windows dialog screen that comes up under this menu option is shown in Figure 3.26.  The various 
entries are described as follows: 

Output Increment 

This numeric entry describes the increments of shaft length for which the SHAFT program will provide 
tabular output of its computational results.  The output increment should be entered in standard units of 
length (either ft or m). 

Plot Options 

This entry allows users to change the numeric values displayed in the vertical axis of output plots.  Users 
can change from the standard “Depth” (with zero value at ground/mudline) values to “Elevation” values, 
which will start from the value entered in this entry (for top of shaft, ground/mudline) and decrease 
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downward along the shaft.  If a negative value is entered here then the resulting elevations will all be 
negative until reaching the shaft tip.  A positive values will decrease and become negative (if the shaft is 
sufficiently long).   

The analysis must be completed (Computation > Run Analysis) in order to display the desired elevation 
values in the resulting graphs.   

Please notice that this is only a change in the numeric values of output plots, it does not change the Depth 
that is used for entering input data. 

Printing Additional t-z Curves 

Users may select to print out the internally-generated t-z curve (load-transfer curve in side resistance) at 
any depth along the modeled shaft.  The resulting output text file (Computation > Edit Output Text) will 
contain the additional t-z curves that correspond to the averaged, upper-bound and lower-bound trend lines.  
These curves correspond only to the initial shaft diameter (if the model defines multiple shaft diameters).   
The plotted additional t-z curves (Graphics > Additional t-z Curves) correspond to the averaged trend 
and also for the initial shaft diameter (if the model defines multiple shaft diameters). 

Please notice that t-z curves are only available for soils and shale.  The concepts of load-vs-deformation for 
sockets in intermediate geomaterials and rock are explained in notes on the accompanying Technical 
Manual and do not separate deformation curves for side resistance and end bearing. 

In models where soils and shale are on top of rock the t-z curves for soils and shale are not taken into 
account.  The load-vs-deformation in those models are based on elastic deformation for the length of shaft 
in soils/shale plus the overall deformation from the socket in the underlying rock. 

End Bearing in Sands 

This dialog box is only applicable for models that have a layer of Sand, Gravel or Gravelly Sand at the tip 
of the shaft.  For those cases the SHAFT program computes end bearing based on recommendations from 
Quiros and Reese (1977) that considers a linear variation of qb from zero at ground surface to maximum 
values (shown in Tables 3.2 and 8.1 of the Technical Manual) at a penetration of 10 pile diameters. 

In Gravelly Sand and Gravel, this assumption of linear interpolation from zero at ground surface may be 
too conservative so designers may choose to use values from Table 3.2 of the Technical Manual according 
to their input and variations of NSPT (Blow Counts) values from ground surface.  For this option the user 
would select the radio button to “Use maximum values at any depth” and enter appropriate values of 
NSPT (Blow Counts) in the applicable Data > Soil Layer Data screens. 

Text Editor 

The user should input in this box the complete path and command line for the preferred-text editor or word 
processor that will be used to examine and print the input, output, and the processor run notes files created 
by the SHAFT program. 

As a default, the command line c:\windows\notepad.exe is used to operate a standard text editor.  Microsoft 
Notepad is included with the Microsoft Windows operating system.  However, the path to the directory 
where notepad.exe is installed varies in different versions of the Microsoft Windows operating system. 
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There may be some instances when the output files are too large for Notepad and a different text editor or 
word processor should be used.  In those cases it is suggested to use Microsoft WordPad 
(c:\windows\wordpad.exe). 

 
Figure 3.26   Entries under Data > Control Options… 

3.3 Help Menu 
This menu provides access to manuals that are installed with SHAFT: User’s Manual and Technical 
Manual.  All manuals are copyrighted and also protected against modifications or copying of its content.  
These manuals are distributed in standard PDF files and should be available for any PDF reader that is 
installed in the user’s computer.  For reference, the original Adobe Reader program is freely distributed by 
Adobe Systems Inc. at www.adobe.com  

Submenu options, shown in Figure 3.27, are briefly described below.  The menu may be accessed at any 
time while in SHAFT. 

http://www.adobe.com/
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 a. Single-User License b. Client on Local Network License 

Figure 3.27   Help Menu 

3.3.1 User’s Manual 

The Help > User’s Manual calls the default PDF-file reader that is installed in the user’s computer and 
opens the PDF file of the SHAFT User’s Manual.  The User’s Manual for SHAFT is contained in the Shaft 
2023 Users Manual.pdf file that is installed with the program. 

3.3.2 Technical Manual 

The Help > Technical Manual calls the default PDF-file reader that is installed in the user’s computer and 
opens the PDF file of the SHAFT Technical Manual.  The Technical Manual for SHAFT is contained in 
the Shaft 2023 Technical Manual.pdf file that is installed with the program. 

3.3.3 About … 

This command provides a dialog describing the program version, date, and methods for accessing technical 
support. Other information about the program licensing and maintenance expiration date, program version, 
and program release date are also shown. 

3.3.4 Check for Updates 

The Help > Check for Updates submenu will start up the default Internet browser and report the user of 
the current program version and maintenance expiration date as well as any new update that is available for 
downloading from Ensoft’s website (www.ensoftinc.com).  Users shall be able to download, install and run, 
in full mode and without the intervention from Ensoft, any SHAFT program release/update that was made 
prior to their maintenance expiration date.  Notice that some anti-virus programs may require the user to 
grant permission to SHAFT to open the Internet browser program. 

3.3.5 Ensoft Key Inquirer 

This submenu is only available on single-user installations of the software product (it is not available for 
users running a network version of the product).  This utility is used to check for licensing information on 
the USB Key that is connected to a working USB port of the computer in use. It provides information such 
as serial number, maintenance expiration date, etc.  This utility is also necessary for a remote update and 
renewal of the license for this product.  This utility is installed in the selected installation directory with the 
following filename: ensoft_key_inquirer_v5.exe (may change with time). 

http://www.ensoftinc.com/
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3.3.6 Check Network Dongle 

This submenu is only available on client computers of network versions of the software product (it is not 
available for users running a single-user version of the product).  This utility helps to check the licensing 
and to troubleshoot communications with a license manager (or software server).  This utility is very useful 
in case of problems in clients while trying to run the licensed software.  This utility is installed in the 
selected installation directory with the following filename: CheckNetworkDongle_ipv_511.exe (may 
change with time). 
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4.1 Introduction  
CHAPTER 4 presents choices related to execution of the program and includes methods of addressing run-
time errors.  This Chapter also includes suggestions for reviewing input, output, and processor text files.  
The final section of this Chapter includes descriptions about all the output curves that may be observed in 
graphical form.  The commands covered in this chapter are contained in the top menu, under the 
Computation and the Graphics titles. 

4.2 Computation Menu 
This menu is selected to execute the program using the parameters that were saved in the input-data file.  
Within the options contained under this menu, shown in Figure 4.1, there are commands that facilitate the 
reviews of the text files produced for storing input data, output results, and processor notes.  In addition, 
the user may select an option to observe a graphical representation of the side view of the modeled pile and 
soil layers.  Detailed description of the submenu options contained under the Computation menu are 
explained in the following topics. 

4.2.1 Computation > Run Analysis 

This command executes the analytical portion of program SHAFT.  The user should remember to save 
the input data under an user-specified name before executing the analytical module.  When saving 
data to disk, SHAFT will automatically add an extension of the type *.sf9d to the name of the input data 
file. 

 

 
Figure 4.1   Commands in the Computation Menu. 

When the execution process is finished the active command is returned to the main SHAFT program with 
a screen indicating that computations are completed.  The user should always check the output text file 
(Computation > View Output Text) for any error or warning messages that were produced during 
computations. 

At the beginning of the computational run the analytical module will read the saved input data.  If an input-
data format is incorrect during reading, the analytical module will stop immediately and in many cases 
display an error message.  A status report may also be saved in a file with the same name as the input but 
with the extension *.sf8r.  This status-report file may be accessed by selecting Computation > View 
Processor-Run Notes. 



CHAPTER 4 – Program Execution and Output Reviews – 4-3 
 

User’s Manual (Rel. Apr/2023)  SHAFT v2023 
 

The analytical module automatically creates an output text file with the same name as the input but with 
the extension *.sf9o.  This file may be accessed by selecting Computation > View Output Text.  Once a 
successful run is produced the user may proceed to the next items for observation of results. 

4.2.2 Computation > View Input Text 

This selection is used to review/edit the input-data file that is currently processed by the program.  This 
command becomes active after new data files have been saved to disk or when opening existing input-data 
files.  The command is helpful for experienced users who may want to change one or two parameters 
quickly using a plain-text editor, or for users wishing to observe the prepared input data in text mode. 

This submenu automatically invokes the word processor or text editor specified in Data > Control 
Options...  The default setting is to use the utility program named notepad.exe provided by Microsoft 
Windows©.  Input-data files are automatically saved to disk with the user-specified file name and the 
extension of *.s98d by program SHAFT.  Use of the notepad program for editing the input data is shown 
in Figure 4.2. 

 
Figure 4.2   Sample use of Microsoft Notepad© for viewing input text of Example 

Problem 1. 

4.2.3 Computation > View Processor Run Notes 

This command is used to view a text file with processor run notes that is automatically produced during 
each analytical run.  This file contains notes produced during the processing of input data. 

Observation of the notes produced during a processor run may become helpful to debug a data file that did 
not produce a successful run.  A successful run usually produces a file of processor-run notes containing 
similar lines of text as those in Figure 4.3. 
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This submenu automatically invokes the word processor or text editor specified under Data > Control 
Options...  The default setting is to use the utility program named notepad.exe provided by Microsoft 
Windows©. 

Files containing processor-run notes are automatically saved to disk with the same file name as the input-
data file but with the extension *.sf9r.  Use of the Microsoft Notepad© for editing the processor- run notes 
for Example Problem 1 is shown in Figure 4.3. 

 

Figure 4.3   Sample Microsoft Notepad © session of processor-run notes for Example 
Problem 1. 

4.2.4 Computation > View Output Text 

This selection is used to edit the output-text file that is automatically produced during each successful 
analytical run.  This command becomes active after new data files have been saved to disk and successfully 
executed, or when opening previously-executed input-data files. 

The submenu automatically invokes the word processor or text editor that was previously specified under 
Data > Control Options...  The default setting is to use the utility program named notepad.exe provided 
by Microsoft Windows©. 

Output files are automatically saved to disk with the same file name as the input-data file but with the 
extension *.sf9o.  Use of Microsoft Notepad© for editing the output file for Example Problem 1 is shown 
in Figure 4.4. 
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Figure 4.4   Sample use of Microsoft Notepad © for editing the output-text file of 
Example Problem 1. 

4.2.5 Computation > View Shaft Elevation 

The Computation > View Shaft Elevation command provides a graphical screen that displays an 
elevation view of the drilled shaft and soil layers along with their various depths.  This command becomes 
active after entries under Drilled-Shaft Properties and Soil Layer Data have been entered in the Data 
menu, or when opening previously-executed input-data files.  A sample graphics of the Computation > 
View Shaft Elevation command option is shown in Figure 4.5. 

Any extension of the drilled shaft above ground surface is only provided for graphical purposes and has no 
implication in the resulting computations (the shaft is only modeled starting from ground surface).  The 
vertical position of the cursor in the screen will display an approximate indication of the depth (from ground 
surface to the cursor position). 
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Figure 4.5   Sample Computation > View Shaft Elevation command.  

4.2.6 Computation > 3D View 

The Computation > 3D View command selection provides a graphical screen of the modeled shaft.  This 
command becomes active after entries under Drilled-Shaft Properties and Soil Layer Data have been 
entered in the Data menu, or when opening previously-executed input-data files.  A sample graphics of the 
Computation > 3D View command option is shown in Figure 4.6. 

The selection of Computation > 3D View introduces a new top menu labeled Show 3D View (see Figure 
4.7) and several new speed buttons (see Figure 4.8). 

4.2.7 Show 3D View Menu 

This menu becomes available when selecting the Computation > 3D View command.  Within this menu 
there are several control features for the displayed 3D graph (see Figure 4.7).  The following menu options 
are self-explanatory on/off features for the displayed graph: Shaft, Water Level, Soil Layers, Layer 
Labels, Layer Depths and Global Axes. 

The Show 3D View > Combined Plots (see Figure 4.9) introduces a graphical display of load transfers 
(either Ultimate or ASD/LRFD) in Skin Friction, Tip Resistance and Total Capacity with pile depth.  
This may be useful to see the influence of specific soil layers in the axial load transfers.  The user may also 
select one graph at a time to automatically display the maximum values on the 3D screen. 
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Figure 4.6   Sample Computation > 3D View command option.  

 
Figure 4.7   Show 3D View menu for Computation > 3D View command option. 
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Figure 4.8   Speed buttons for Computation > 3D View command option. 

 

Figure 4.9   Show 3D View > Combined Plots Dialog Screen. 

4.3 Graphics Menu 
This menu is selected to observe the different graphical representations of the program results contained in 
the output file.  Sample submenu options contained under this menu are shown in Figure 4.10.  Not all of 
the graphics may be enabled for observation, active curves depend on specifications contained in the input. 

All of the graphical representation of output data that may be produced by the program are contained in the 
following commands of the Graphics menu: 

Ultimate Skin Friction vs Depth 
Ultimate Tip Resistance vs Depth 
Ultimate Total Capacity vs Depth 
Combined Plots vs Depth (Initial Diameter) 

ASD/LRFD Skin Friction vs Depth 
ASD/LRFD Tip Resistance vs Depth 
ASD/LRFD Total Capacity vs Depth 



CHAPTER 4 – Program Execution and Output Reviews – 4-9 
 

User’s Manual (Rel. Apr/2023)  SHAFT v2023 
 

Combined Plots vs Depth (Initial Diameter) 

Axial Load vs Settlement (averaged) 
Axial Load vs Settlement (upper bound) 
Axial Load vs Settlement (lower bound) 
Combined Plots of Load vs Settlement (Initial Diameter) 

t-z Curves (averaged, initial diameter) 
Q-w Curves (averaged) 
Additional t-z Curves (averaged, initial diameter) 
Design Charts (xx movement) 

Export Plots to Excel 

The observation of any of the above-listed curves will activate the graphics mode of SHAFT.  Several 
changes occur during use of the graphics mode: new mouse commands are enabled and a new top-menu 
option (Plot) becomes available. 

 

 
Figure 4.10   Sample Graphics Menu. 
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4.3.1 Mouse Commands in the Graphics Mode 

Table 4.1 describes mouse commands that become enabled automatically during all graphical observations 
of output curves. 

 
Event Description 
Mouse Left Click Zooms in on the graphics at the clicked position  (up to five zoom levels) 
Mouse Right Click Zooms out from the graphics 
Mouse Double Click on Legend Turns the selected curve on/off at every click 

Table 4.1  Mouse commands in the graphics mode 
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4.3.2 Graphics > Ultimate Skin Friction vs Depth 

This selection provides a curve(s) of the ultimate skin friction (side resistance) versus depth for the 
modeled-drilled shaft.  This curve is automatically generated in all analytical runs of a drilled shaft.  The 
data value at each depth represents the unfactored, total friction (ultimate values) from the ground surface 
down to that depth.  A single curve is presented if the model involves only one shaft diameter.  Several 
curves are provided when the model involves multiple pile diameters. 

A sample screen of the Graphics > Ultimate Skin Friction vs Depth command option is shown in Figure 
4.11.  In cases of uplift, the values of skin friction represented in the graphics have been modified by the 
reduction factor that was specified for uplift loads (under Data > Computations Method).  The values of 
skin friction, although reduced for uplift, are still ultimate and do not take into account the specified load 
factors. 

 

Figure 4.11   Ultimate Skin Friction vs Depth command option for Example Problem 1. 
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4.3.3 Graphics > Ultimate Tip Resistance vs Depth 

This selection provides a curve(s) of the ultimate tip resistance versus depth for the modeled-drilled shaft.    
The data value at each depth represents the unfactored, tip resistance (ultimate values) developed at that 
depth.  A single curve is presented if the model involves only one shaft diameter.  Several curves are 
provided when the model involves multiple pile diameters. 

A sample graphics screen of the Graphics > Ultimate Tip Resistance vs Depth command option is 
shown in Figure 4.12.  The curve of Tip Resistance vs Depth is disabled (not applicable) for models with 
uplift loads. 

 

 
Figure 4.12   Ultimate Tip Resistance vs Depth command option for Example Problem 1. 
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4.3.4 Graphics > Ultimate Total Capacity vs Depth 

This selection provides a graphical representation of the curve(s) of the ultimate total capacity versus depth 
for the modeled-drilled shaft.  This curve is automatically generated in all analytical runs of an axially-
loaded drilled shaft.  The data value at each depth represents the unfactored, total capacity (ultimate loads) 
from the ground surface down to that depth.  A sample graphics screen of the Graphics > Ultimate Total 
Capacity vs Depth command option is shown in Figure 4.13. 

Values of total capacity are equal to skin friction plus tip resistance for compressive loads.  Total capacity 
is equal to skin friction plus shaft weight for uplift loads.  For uplift loads, the displayed values have been 
modified according to the reduction factor that the user has previously specified (under the Data > 
Computations Method).  The values of Ultimate Total Capacity, although reduced for uplift (if selected), 
are still ultimate and do not take into account the specified factors of safety. 

 

Figure 4.13   Ultimate Total Capacity vs Depth for Example Problem 1. 
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4.3.5 Graphics > Combined Plots vs Depth (ultimate) 

This selection provides a graphical representation of the curves of ultimate skin friction, ultimate tip 
resistance, and ultimate total capacity versus depth for the modeled-drilled shaft all combined on the same 
plot.  These curves are automatically generated in all analytical runs of an axially-loaded drilled shaft.  The 
data value at each depth represents the unfactored, total capacity (ultimate loads) from the ground surface 
down to that depth.  A sample graphics screen of the Graphics > Combined Plots vs Depth command 
option is shown in Figure 4.18. 

Values of total capacity are equal to skin friction plus tip resistance for compressive loads.  Total capacity 
is equal to skin friction plus shaft weight for uplift loads.  For uplift loads, the displayed values have been 
modified according to the reduction factor that the user has previously specified (under the Data > 
Computations Method).  The capacity values, although reduced for uplift (if selected), are still ultimate 
and do not take into account the specified factors of safety.  In models evaluating multiple shaft diameters, 
the combined plots are only for the drilled shaft with the initial diameter (smallest). 

 

Figure 4.14   Combined Plots vs Depth (Ultimate) for Example Problem 1. 
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4.3.6 Graphics > ASD/LRFD Skin Friction vs Depth 

The user may select this command to observe a graphical representation of the curve of skin friction (side 
resistance) versus depth for the modeled-drilled shaft.  This curve is automatically generated in all analytical 
runs of a drilled shaft. The data value at each depth represents the factored, total friction from the ground 
surface down to that depth.  In ASD analyses the curve uses the factor of safety that the user specified for 
ultimate side friction under the Data > Factor of Safety menu.  In LRFD analyses the curve uses the 
resistance factors for Side Friction of each soil layer that the users specified under the Data > Soil Layer 
Data menu. 

A sample graphics screen of the ASD/LRFD Skin Friction vs Depth command option is shown in Figure 
4.15.  In cases of uplift, the values of skin friction represented in the graphics have been modified by the 
reduction factor that was specified for uplift loads. 

 

Figure 4.15   Skin Friction vs. Depth (w/F.S.) for Example Problem 1. 
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4.3.7 ASD/LRFD Graphics > Tip Resistance vs Depth 

This command option is selected to observe a graphical representation of the curve of tip resistance versus 
depth for the modeled pile.  This curve is automatically generated in all analytical runs of a drilled shaft, 
except for cases with uplift loads.  In ASD analyses the curve uses the factor of safety for ultimate base 
capacity that the user specified under the Data > Factor of Safety menu.  In LRFD analyses the curve 
uses the resistance factors for End Bearing of each soil layer that the users specified under the Data > Soil 
Layer Data menu. 

The data value at each depth represents the factored, tip resistance developed at that depth.  A sample 
graphics screen of the ASD/LRFD Tip Resistance vs Depth command option is shown in Figure 4.16.  
The curve of Tip Resistance vs Depth is disabled for uplift loads. 

 

Figure 4.16   Tip Resistance vs Depth (w/F.S.) for Example Problem 1. 
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4.3.8 ASD/LRFD Graphics > Total Capacity vs Depth 

This selection provides a graphical representation of the curve of total capacity versus depth for the 
modeled-drilled shaft.  This curve is automatically generated in all analytical runs of an axially-loaded 
drilled shaft.  The data value at each depth represents the factored, total capacity from the ground surface 
down to that depth.  A sample graphics screen of the ASD/LRFD Total Capacity vs Depth command 
option is shown in Figure 4.17. 

Values of total capacity are equal to skin friction plus tip resistance for compressive loads.  Total capacity 
is equal to skin friction plus shaft weight for uplift loads.  For uplift loads, the values have been modified 
according to the reduction factor that the user has previously specified under the Data > Computations 
Method menu.  In ASD analyses the curve uses the factor of safety for ultimate base capacity and for 
ultimate side friction that the user specified under the Data > Factor of Safety menu.  In LRFD analyses 
the curve uses the resistance factors for End Bearing and Side Friction of each soil layer that the users 
specified under the Data > Soil Layer Data menu. 

 

Figure 4.17 Total Capacity vs Depth (w/F.S.) for Example Problem 1.  
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4.3.9 Graphics > Combined Plots vs Depth (ASD/LRFD) 

The user may select this command option to observe a graphical representation of the curves of skin friction, 
tip resistance, and total capacity, all with a factor of safety applied, versus depth for the modeled-drilled 
shaft on the same plot.  This curve is automatically generated in all analytical runs of a drilled shaft. 

A sample graphics screen of the Combined Plots vs Depth (ASD/LRFD) command option is shown in 
Figure 4.18.  In ASD analyses the curve uses the factor of safety for ultimate base capacity and for ultimate 
side friction that the user specified under the Data > Factor of Safety menu.  In LRFD analyses the curve 
uses the resistance factors for End Bearing and Side Friction of each soil layer that the users specified under 
the Data > Soil Layer Data menu.  In models evaluating multiple shaft diameters, the combined plots are 
only for the drilled shaft with the initial diameter (smallest). 

 

Figure 4.18   Combined Plots vs Depth (w/F.S.) for Example Problem 1. 

  



CHAPTER 4 – Program Execution and Output Reviews – 4-19 
 

User’s Manual (Rel. Apr/2023)  SHAFT v2023 
 

4.3.10 Graphics > Axial Load vs Settlement (Averaged) 

This selection provides a graphical representation of the curves of axial load versus settlement for the 
modeled drilled shaft based on the trend (averaged) curves shown in the FHWA manual.  This curve is 
automatically generated in all analytical runs of a drilled shaft.  A sample graphics screen of the Axial Load 
vs Settlement (Averaged) command option is shown in Figure 4.19. 

 

 

Figure 4.19   Axial Load vs Settlement (averaged) for Example Problem 1. 
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4.3.11 Graphics > Axial Load vs Settlement (Upper Bound) 

This selection provides a graphical representation of the curves of axial load versus settlement for the 
modeled drilled shaft based on the upper-bound curves shown in the FHWA manual.  This curve is 
automatically generated in all analytical runs of a drilled shaft.  A sample graphics screen of the command 
option is shown in Figure 4.20. 

 

 

Figure 4.20   Axial Load vs Settlement (upper bound) for Example Problem 1. 
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4.3.12 Graphics > Axial Load vs Settlement (Lower Bound) 

This selection provides a graphical representation of the curves of axial load versus settlement for the 
modeled drilled shaft based on the lower-bound curves shown in the FHWA manual.  This curve is 
automatically generated in all analytical runs of a drilled shaft.  A sample graphics screen of the Axial Load 
vs Settlement (Lower Bound) command option is shown in Figure 4.21. 

 

 

Figure 4.21   Axial Load vs Settlement (lower bound) for Example Problem 1. 
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4.3.13 Graphics > Combined Plots of Load vs Settlement 

The user may select this command option to observe a graphical representation of the curves of axial load 
versus settlement for the modeled drilled shaft based on the trend (averaged), upper-bound, and lower-
bound curves shown in the FHWA manual.  These combined plots provide the user with some comparison 
between each condition.  For the analysis using multiple diameters, this graphics will only display the 
combined plots for the drilled shaft with the initial diameter (smallest).  A sample graphics screen of the 
Combined Plots of Load vs Settlement is shown in Figure 4.22. 

 

Figure 4.22   Combined Axial Load vs Settlement Curves for Example Problem 1. 
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4.3.14 Graphics > t-z curves 

This command displays a selection of t-z curves that were generated by the SHAFT program for each soil 
layer.  Five curves are normally displayed for each soil layer, the t-z curves are for near the top and bottom 
of each layer plus three intermediate depths.  For internal computations the SHAFT program generates t-z 
curves at every finite increment but the printout for display is only for the five selected depths.  For analyses 
using multiple diameters, the displayed t-z curves are only for the drilled shaft with the initial diameter 
(smallest).  Also, these t-z curves correspond to the trend (averaged) curves shown in the FHWA manual.  
A sample graphics screen of the t-z curves is shown in Figure 4.23. 

Please notice that t-z curves are only available for soils and shale.  The concepts of load-vs-deformation for 
sockets in intermediate geomaterials (IGM) and rock are explained in notes on the accompanying Technical 
Manual and do not separate deformation curves for side resistance and end bearing. 

In models where soils and shale are on top of IGM/rock the t-z curves for soils and shale are not taken into 
account.  The load-vs-deformation in those models are based on elastic deformation for the length of shaft 
through the soils/shale layer(s) plus the overall deformation from the socket in the underlying IGM/rock. 

In models where a layer of IGM or rock is placed between layers of soils and shale the models of load-vs-
deformation for IGM/rock are not taken into account.  The load-vs-deformation in those models are based 
on the elastic deformation for the length of shaft through the IGM/rock plus the t-z curves for the layers of 
soils/shale. 
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Figure 4.23   t-z curves for Example Problem 1. 

4.3.15 Graphics > Q-w curves 

This command displays the Q-w curves that were generated by the SHAFT program for the analyzed model.  
The program will display more than one Q-w curve in models that specify multiple shaft diameters.  Also, 
these Q-w curves correspond to the trend (averaged) curves shown in the FHWA manual.  A sample 
graphics screen of the Q-w curves is shown in Figure 4.24. 

Please notice that Q-w curves are only available for soils and shale.  The concepts of load-vs-deformation 
for sockets in intermediate geomaterials and rock are explained in notes on the accompanying Technical 
Manual and do not separate deformation curves for side resistance and end bearing. 
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Figure 4.24   Q-w curves for Example Problem 1. 

4.3.16 Graphics > Additional t-z curves 

This menu option is only available in models where users selected to print additional t-z curves (under Data 
> Control Options > Print Internally-Generated t-z Curves for Verification).  The command displays 
the t-z curves that were used by the SHAFT program for the user-specified soil depths.  For analyses using 
multiple shaft diameters, the displayed t-z curves are only for the drilled shaft with the initial diameter 
(smallest).  Also, these t-z curves correspond to the trend (averaged) curves shown in the FHWA manual.  
A sample graphics screen of the Additional t-z curves is shown in Figure 4.25. 

Please notice that t-z curves are only available for soils and shale.  The concepts of load-vs-deformation for 
sockets in intermediate geomaterials (IGM) and rock are explained in notes on the accompanying Technical 
Manual and do not separate deformation curves for side resistance and end bearing. 

In models where soils and shale are on top of IGM/rock the t-z curves for soils and shale are not taken into 
account.  The load-vs-deformation in those models are based on elastic deformation for the length of shaft 
through the soils/shale layer(s) plus the overall deformation from the socket in the underlying IGM/rock. 
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In models where a layer of IGM or rock is placed between layers of soils and shale the models of load-vs-
deformation for IGM/rock are not taken into account.  The load-vs-deformation in those models are based 
on the elastic deformation for the length of shaft through the IGM/rock plus the t-z curves for the layers of 
soils/shale. 

 

Figure 4.25   Sample plot for additional t-z curves.  
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4.3.17 Graphics > Design Chart (xx movement) 

This menu option is only available in models where users selected to plot ASD/LRFD Design Charts 
(under the Data menu).  The command displays the curves of axial capacity versus depth for the user-
specified settlements.  Also, these t-z curves correspond to the trend (averaged) curves shown in the FHWA 
manual.  A sample graphics screen of the Design Chart (0.1-in movement) for Example Problem 11 is 
shown in Figure 4.26. 

 
Figure 4.26   Design Chart (0.1-in movement) for Example Problem 11. 

4.3.18 Graphics > Export Plots to Excel 

This command is selected to export some (or all) of the output plots to a pre-formatted spreadsheet file for 
Microsoft Excel©.  Each check-marked plot will be exported to two spreadsheet tabs, one contains the data 
points and the second the plotted chart.  A sample graphics screen of the Graphics > Export Plots to 
Excel dialog box is shown in Figure 4.27. 

Options contained in this dialog box are explained below. 

Add Markers in Plots 
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Adds markers for all the points in each plotted graph. 

Select All 
Marks all available plots for export to an Excel file. 

Unselect All 
Unselect all available plots so none will be exported. 

Generate Excel File 
After clicking this button the Microsoft Excel software will be started (only if available in the computer in 
use).  The user must wait until all the data has been exported to the file.  User must save the generated excel 
file before closing. 

Close Window 
Click this button to close the Export to Excel dialog box. 

 
Figure 4.27   Sample Export Plots to Excel dialog box. 

4.4 Plot Menu 
This menu command only appears in the top-menu bar while in the graphics mode (when observing any 
output graphics).  Command options contained in this menu, shown in Figure 4.28, are explained below.  
Notice that none of the parameters selected in this menu command are not saved with the output file and 
must be changed each time the file is opened. 

Show Legend 
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This activates or deactivates the floating legend included in the graphics mode.  The legend box can be 
moved with click-and-drag operations of the mouse to any position in the graphics screen.  Despite its 
location in the screen, the legend is always located at the right-bottom corner on the printouts. 

Show Soil Layers 

Click this menu-item to activate or deactivate a soil profile plotted at the right side of the graphics.  This 
option is not available in some plots (where not applicable). 

Show Markers 

This menu provides the option to activate or deactivate the markers for each point of all the curves displayed 
in the active screen of the graphics mode.  By default, the program automatically plots at every foot of 
penetration, or every 30 cm when using metric units.  The user may optionally select to show markers every 
1, 2, 3, 5, or 10 increments of unit.  The type of markers used in each curve is automatically selected by the 
program.  Once activated, the markers are enabled for all visible curves of the active graphics screen. 

Font Sizes 

This menu provides the option to enlarge the default size of fonts used in plots.  The user may optionally 
select to enlarge the font by 1.5, 2, 2.5, 3, or 4 times of the default size. 

Line Width 

This menu provides the option to enlarge the default width of lines used in plots.  The user may optionally 
select to enlarge the width by 2, 4, 6, or 10 times of the default width. 

Graph Title 

The user may optionally add a title to the active graphics using this command.  However, the parameters 
selected here are not saved with the output file and must be changed each time the file is opened. 

Edit Legend 

The user may change the text of the legend in the active graphics using this command.  However, the 
modified names are not saved with the output file and must be changed each time the file is opened. 

Print... 

This command is used to produce a hard copy of the active graphics screen.  The Print dialog box includes 
a drop-down menu that allows the user to select any of the installed Windows printers, allows for change 
of printer properties, and allows the selection of the total number of copies to be printed.  The printed 
graphics is sized according to the margins that the user specifies in the Plot > Page Setup menu. 

Page Setup 

The user can here specify the printed size of the active-graphics screen.  The size of the plot is based on the 
specified margins and selection of paper orientation.  The parameters selected here are not saved with the 
output file and must be changed each time that the graphics is plotted. 

Active Graphs... 

This command is used to activate or de-activate the graphs that are displayed on the screen. 
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Save to Disk... 

This command is used to save the active-graphics screen to disk.  The format of the saved file is as bmp 
graphics (bitmap file), which is the internal-file format used in Microsoft Windows©. 

 

 
Figure 4.28   Sample Plot Menu. 
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5.1 Introduction  
This chapter presents several example problems studied using the computer program SHAFT.  In order to 
ensure accuracy from the computer results, some examples have been compared with results from hand 
calculations.  The step-by-step hand calculations in this chapter are carried out based on the procedures 
described in the Technical Manual.  The user can have confidence in their results if hand calculations are 
performed for comparison.  The studies in this chapter also provide additional guidance for the method of 
analyses of axially loaded piles with SHAFT. 

Several problems are provided herein as examples of different applications that may be solved using our 
computer program SHAFT.  Each example focuses on a particular computational feature of the program.  
Input files for each example are automatically copied to the SHAFT data directory during installation (Root 
Drive\Ensoft\Shaft2023-Examples). 

Example problems provide the user information on input and output of various cases, and present a quick 
tutorial for real-world applications.  The user is encouraged to study these examples and, with 
modifications, may even use them to solve similar problems.  However, by no means can these limited 
examples explore the full functions and features provided by SHAFT. 

The main features of each example included with SHAFT are summarized as follows. 

Example 1 ..... Drilled shaft in sand 
• varying pile diameter from 3 ft to 6 ft (in 0.5-ft increments), 

• method for sand (user-specified values), 
• inputted values of blow counts, NSPT, from Standard Penetration Tests for sand properties. 

Example 2 ..... Drilled shaft in layers of clay and sand 
• top two layers of clay, 

• ignored side resistance on top 5 ft, 

• internally-generated values of Nc, 

• bottom three layers of sand, and 

• method for sand (using internally-generated values). 

Example 3 ..... Belled shaft in clay 
• two layers of clay, 
• variable cu on top layer of clay, 

• small bell at bottom, 

• ignored side resistance at top 5 ft, and 

• ignored side resistance at bottom one diameter over bell. 

Example 4 ..... Belled shaft in silty sand/clay 
• three layers of clay, 

• one intermediate layer of sand, 
• method for sand (user-specified values), 
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• large bell at bottom, 

• ignored side resistance at top 5 ft, and 

• ignored side resistance at bottom one diameter over bell. 

Example 5 ..... Drilled shaft in strong rock 
• top layer of clay, and 
• bottom is dolomite rock (strong rock). 

Example 6 ..... Drilled shaft in weak rock 
• top layer of sand, 

• bottom is a weak rock, and 

• example with metric units. 

Example 7 ..... Drilled shaft in gravel (decomposed rock) 
• top layer of sand with neglected skin friction, 

• two bottom layers of decomposed rock, 

• internally generated elastic modulus of decomposed rock based on blow counts (NSPT), and 
• example with metric units. 

Example 8 ..... Drilled shaft in gravelly sand and gravel 
• top layer of sand, 

• two bottom layers of gravelly sand and gravel strata, 

• internally generated Beta values for gravel based on blow counts (NSPT), and 

• example with English units. 

Example 9 ..... Model using the LRFD method 
• top layer of clay, 

• bottom layer with sand, 
• separate resistance factors used for side resistance and end bearing for each soil layer. 

Example 10 ..... Model using Multiple Shaft Lengths 
• same shaft (3-ft OD) and soils (sand) as Example 1, 
• study of load-vs-settlement for multiple shaft lengths from 42-ft to 60-ft. 

Example 11 ..... Model using Design Charts 
• same soils (clay/sand) as Example 2, 

• checked response for shaft diameters from 3-ft OD to 7-ft OD and multiple lengths from 24-ft 
to 60-ft. 
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5.2 Example Problem 1 – Sand 
This is an example of a shaft drilled into sand.  The example has been studied in the referenced literature 
of Reese and O’Neill, 1988.  The example is also modeled after load tests in sand, Owens and Reese, 1982. 

5.2.1 Soil Profile 

The soil profile is shown in Figure 5.1.  The water table is at a depth of 4 ft below the ground surface. 

5.2.2 Soil Properties 

N-values (blow counts per foot) from the Standard Penetration Test are included in Figure 5.1. 

 
Figure 5.1   General soil description of Example Problem 1. 

5.2.3 Construction 

High-quality construction is assumed.  The contractor will have all the required equipment in good order 
and experienced personnel will be on the job. 

5.2.4 Loadings 

The working-axial load is 170 tons, lateral load is negligible, and no downdrag is expected. 

5.2.5 Factor of Safety 

It is assumed that a load test has been performed nearby but considering the possible variation in the soil 
properties over the site and other factors, an overall factor of safety of 2.5 is selected.  The diameter will be 



CHAPTER 5 – Example Problem 1 – 5-5 
 

User’s Manual (Rel. Apr/2023)  SHAFT v2023 
 

sufficiently small so that reduced-end bearing will not be required.  Consequently, the global factor of safety 
can be applied to both components of resistance. 

5.2.6 Ultimate Load 

The ultimate-axial load is thus established as 2.5 x 170 = 425 tons, since a global factor of safety (of 2.5) 
is used. 

5.2.7 Geometry of the Drilled Shaft 

A straight drilled shaft is selected with a diameter of 3.0 ft and a penetration of 60 feet. 

5.2.8 Hand Computations 

Side Resistance 

Computations are performed assuming a total-unit weight of sand equal to 115 pcf.  The hand computations 
are as follows: 

Depth Interval ∆A Avg. Effective Stress β ∆Qs 
ft ft2 Tsf  Tons 

0-4 37.7 0.115 0.8 3.5 
4-30 245.0 0.572 0.8 112.1 

30-60 282.7 1.308 0.6 221.9 
 Qs = 337.5 

Base Resistance 

Computations for base resistance are performed using the soil at the base of the shaft. 

At the 60-ft tip penetration: 
NSPT= 21 
qB = (0.6) (21) = 12.6 tsf 
AB = 7.07 ft2 
QB = (7.07) (12.6) = 89.1 tons 

Total Resistance 
QU = 337.5 + 89.1 = 427 tons ≈ QT= 425 tons (OK). 

5.2.9 Comparison of Results 

Table 5.1 contains a comparison of the results obtained from hand computations against those from 
computer run in SHAFT (3-ft diameter). 

Category Manual Calculations 
(tons) 

Computer Analysis 
(tons) 

Deviation 

Side Resistance 338 337.6 0.1% 
Tip Resistance 89 89.1 0% 
Total Capacity 427 426.7 0% 

Table 5.1   Comparison of results for Example Problem 1 
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5.2.10 Input and Output Data Files for Example 1 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Shaft2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

Input-data filenames for Example 1 are the following: 

Examplev9-1-GEC10.sf9d 

Examplev9-1-Sand-MultDiam.sf9d 

The output-data filenames for Example 1 are the following: 

Examplev9-1-GEC10.sf9o 

Examplev9-1-Sand-MultDiam.sf9o 

5.2.11 Graphical Results of Computer Analysis 

Each of the resulting plots of skin friction, tip resistance, and total capacity versus depth (w/F.S.) provided 
by the computer program contains seven curves, as may be seen in Figure 5.2, Figure 5.3 and Figure 5.4 
respectively.  These curves correspond to six increments in drilled shaft diameter, since the data input 
specified 6 ft as the largest and 3 ft as the smallest diameters for consideration.  The program automatically 
computed results for the smallest diameter and for each 0.5-ft increase in diameter up to the largest specified 
by the user. 

Results of combined plots versus depth, shown in Figure 5.5, only contains the curves of skin friction, tip 
resistance, and total capacity versus depth for the initial shaft diameter. 
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Figure 5.2   Curve of Skin Friction vs Depth (w/F.S.) for Example Problem 1. 

 

Figure 5.3   Curve of Tip Resistance vs Depth (w/F.S.) for Example Problem 1. 
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Figure 5.4   Curve of Total Capacity vs Depth (w/F.S.) for Example Problem 1. 

 

Figure 5.5   Curve of Combined Plots vs Depth (w/F.S.) for Example Problem 1. 
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5.3 Example Problem 2 – Mixed Clay/Sand 
This is an example of a shaft drilled into a soil of a mixed profile with layers of clay and sand.  The example 
is modeled after load tests performed and reported by Touma and Reese, 1972, at the G1 site. 

5.3.1 Soil Profile 

The soil profile is shown in Figure 5.6.  The water table is at a depth of 17 ft below the ground surface. 

5.3.2 Soil Properties 

Values of undrained shear strength obtained from laboratory tests and N-values (blow counts per foot) from 
the Standard Penetration Test are included in Figure 5.6.  Top 5 ft of clay is assumed with no strength for 
transfers in side resistance (unit weight is considered). 

 

Figure 5.6   General soil description of Example Problem 2. 

5.3.3 Construction 

High-quality construction, good specifications, and excellent inspection are assumed. 

5.3.4 Loadings 

Working axial load is 150 tons, no downdrag is expected, and lateral loading is negligible.  The depth to 
the zone of seasonal moisture change is judged to be about 10 feet. 

5.3.5 Factor of Safety 

Soil conditions across the site are variable, and the foundation is for a major and complex structure.  An 
overall factor of safety of 3.0 was selected. 

5.3.6 Ultimate Load 

Using the factor of safety of 3, the ultimate axial load is computed to be 450 Tons. 
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5.3.7 Geometry of the Drilled Shaft 

A straight shaft is selected with a diameter of 3.0 ft and a penetration of 59 feet. 

5.3.8 Hand Computations 

Side Resistance 

Computations are performed assuming a total unit weight of clay equal to 125 pcf and total unit weight of 
sand equal to 115 pcf.  For ease of hand computations, an average value of β was selected for the sand 
layer.  However, the computer program has been instructed to generate internally the values of β and to 
interpolate linearly with depth.  The hand computations are as follows: 

Soil Depth Interval ∆A Avg. effective stress αz ∆Qs 
Type ft. ft2 tsf or β tons 
Clay 0-5 --- (cased) 0 0 
Clay 5-32 207.3 0.81 0.55 116.7 
Sand 32.59 254.5 1.887 0.6 288.1 

 Qs = 404.8 

Base Resistance 

Computations for base resistance are performed using the soil at the base of the shaft. 

At the 59-ft location: 
NSPT= 25. 
qB = (0.6) (25) = 15.0 tsf 
AB = 7.07 ft2 

QB = (7.07) (15.0) = 106.0 tons 

Total Resistance 
QU = 404.8 + 106.0 = 510 tons > QT= 450 tons (OK). 

5.3.9 Comparison of Results 

Table 5.2 contains a comparison of the results obtained from hand computations against those from 
computer run in SHAFT. 

Category Manual Calculations 
(tons) 

Computer Analysis 
(tons) 

Deviation 

Side Resistance 405 391(a) -3.4% 
Tip Resistance 106 129(b) 21.7% 
Total Capacity 510 519 1.8% 
(a) Values of β were generated at the top and bottom of each sand layer and 

were interpolated linearly by the program. 
(b) The computer takes into account soil properties of two diameters below the 

bottom of the drilled shaft. 

Table 5.2   Comparison of results for Example Problem 2 
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5.3.10 Input and Output Data Files for Example 1 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Shaft2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 2 is the following: 

Examplev9-2-Mixed Clay-Sand.sf9d 

The output-data filename for Example 2 is the following: 

Examplev9-2-Mixed Clay-Sand.sf9o 

5.3.11 Graphical Results of Computer Analysis 

Resulting plots of ultimate skin friction, ultimate tip resistance, and ultimate total capacity versus depth 
provided by the computer program may be observed in Figure 5.7, Figure 5.8 and Figure 5.9 respectively.  
Results of axial load versus short-term settlement are included in Figure 5.10. 

To introduce another program feature, Figure 5.11 shows a graphical display of the shaft and soil layers 
along with a plot of ultimate load transfers in side resistance.  This type of graph may help to display the 
importance of each soil layer for various load transfers selected in the Show 3D View > Combined Plots 
menu. 

 
Figure 5.7   Curve of Ultimate Skin Friction vs Depth for Example Problem 2. 
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Figure 5.8  Curve of Ultimate Tip Resistance vs Depth for Example Problem 2. 

 

Figure 5.9   Curve of Ultimate Total Capacity vs Depth for Example Problem 2. 
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Figure 5.10   Curve of Axial Load vs Settlement (averaged) for Example Problem 2. 

 

Figure 5.11   Graphical plot of ultimate skin friction with depth for Example Problem 2. 
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5.4 Example Problem 3 – Clay 
This is an example of a shaft drilled into clay and with a small bell at the tip.  The example is modeled after 
load tests performed and reported by Whitaker and Cooke, 1966, Pile A. 

5.4.1 Soil Profile 

The soil profile is shown in Figure 5.12.  The clay is overconsolidated.  The depth to the water table was 
not given and is not needed in capacity calculations (with cohesive soil).  However, the water table should 
be obtained for construction considerations. 

5.4.2 Soil Properties 

Values of undrained shear strength obtained from laboratory tests are included in Figure 5.12. 

 
Figure 5.12   General soil description of Example Problem 3. 

5.4.3 Construction 

High-quality construction, good specifications, and excellent inspection are assumed. 

5.4.4 Loadings 

Working axial load is 230 tons, no downdrag is expected, expansive clay is not a problem, and lateral 
loading is negligible.  The depth to the zone of seasonal moisture change is judged to be about 10 feet. 

5.4.5 Factor of Safety 

It is assumed that a load test has been performed in the area, that the design parameters have been proven, 
and that the soil conditions across the site are relatively uniform; therefore, an overall factor of safety of 
2.0 was selected. 

5.4.6 Ultimate Load 

Using a factor of safety of 2, the ultimate axial load was computed to be 460 tons. 
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5.4.7 Geometry of the Drilled Shaft 

An under-reamed shaft was selected to penetrate a total of 40 ft into the clay.  The height of the bell is 4.0 
ft, making the length of the straight-sided portion 36.0 feet.  The diameter of the straight-sided portion of 
the shaft is 2.58 ft and the diameter of the bell is 5.5 feet.  Since 5.5 ft (66 in) is less than 75 in, reduced 
end bearing need not be considered.  A rotated graphical representation of this model using the 
Computation > 3D View feature along with displayed soil layers and depths is shown in Figure 5.13. 

 

Figure 5.13   3D View of Example Problem 3. 

5.4.8 Hand Computations 

Side Resistance 

For ease of hand computations, it is assumed a constant value of Az equal to 0.55 and an average cu of 
2,280 psf.  However, the computer program interpolates linearly the top and bottom values of cu with depth.  
The hand computations are as follows: 

Depth interval 
ft. 

∆A 
ft2 

Avg. effective 
stress, tsf 

αz 
 

∆Qs 
tons 

0-5   0 0 
5-33.4 230.2 1.14 0.55 144.3 
33.4-40   0 0 

 Qs=144.3 

Base Resistance 

The average undrained shear strength over one base diameter below the base is 1.48 tsf and the area of the 
base is 23.76 ft2. 

qB = (1.48) (9) = 13.32 tsf 
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AB = 23.76 ft2 
QB = (13.32) (23.76) = 316.5 tons 

Total Resistance 
QU = 144.3 + 316.5 = 461 tons ≈ QT= 460 tons  (OK). 

5.4.9 Comparison of Results 

Table 5.3 contains a comparison of the results obtained from hand computations against those from 
computer run in SHAFT. 

*values of cu at the top and bottom of the clay layer were interpolated linearly by the 
program  

Table 5.3   Comparison of results for Example Problem 3 

5.4.10 Input and Output Data Files for Example 1 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Shaft2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 3 is the following: 

Examplev9-3-Clay-Belled Shaft.sf9d 

The output-data filename for Example 3 is the following: 

Examplev9-3-Clay-Belled Shaft.sf9o 

5.4.11 Graphical Results of Computer Analysis 

The resulting plot of combined ultimate axial capacities versus depth provided by the computer program 
may be observed in Figure 5.14.  Results of axial load versus short-term settlement are included in Figure 
5.15. 

Category Manual Calculations 
(tons) 

Computer Analysis 
(tons) 

Deviation 

Side Resistance 144 139* -3.5% 
Tip Resistance 317 330 -4.1% 
Total Capacity 461 469 1.7% 
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Figure 5.14   Curve of Combined Plots vs Depth (ultimate) for Example Problem 3. 

 

Figure 5.15   Curve of Axial Load vs Settlement (combined) for Example Problem 3. 
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5.5 Example Problem 4 – Belled, Silty Sand & Silty Clay 
This is an example of a drilled shaft with an enlarged base (belled tip) into layers of silty sand and sandy 
clay. 

5.5.1 Soil Profile 

The soil profile is shown in Figure 5.16.  The water table is at a depth of 10 ft during part of the year.  The 
depth of seasonal moisture change is 5 feet (ignored for transfers in side resistance). 

5.5.2 Soil Properties 

Values of undrained shear strength obtained from laboratory tests and the N-values from the Standard 
Penetration Test are included in Figure 5.16.  The N value for the interbedded silt and fine sand is 18. 

 
Figure 5.16   General soil description of Example Problem 4. 

5.5.3 Construction 

Advantage is to be taken of the strong bearing material below the sand, and a large bell will be installed.  
High-quality construction (including elimination of water from the bell), good specifications, and excellent 
inspection are assumed.  Slurry and casing will be employed to a depth of 24 feet. 

5.5.4 Loading 

The working axial load is 640 tons, distributed as 500 tons dead load and 140 tons live load.  No downdrag 
is expected, no lateral loading is to be considered and effects of expansive clays near the surface are to be 
considered in a separate analysis. 

5.5.5 Factor of Safety 

No load test has been conducted but soil conditions are consistent across the site and are familiar to the 
designer.  A global factor of safety of 2.5 is selected. 
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5.5.6 Geometry of the Drilled Shaft 

A belled shaft with a 12-ft-diameter bell cut at 45 degrees at a depth of 40 feet is initially designed.  The 
shaft is also designed with a 4-ft diameter straight portion. 

5.5.7 Hand Computations 

Side Resistance 

For ease of hand computations, average values of αz and β were selected for the clay and sand layers.  In 
this model, the computer program has been instructed to use internally the same constant values of αz and 
β that are used in the hand computations.  The hand computations are as follows: 

Soil 
Type 

Depth interval 
ft. 

∆A 
ft2 

Avg. effective 
stress, tsf 

αz 
or β 

∆Qs 
tons 

Clay 0-5 62.8 1.5 0 0 
Clay 5-10 62.8 1.5 0.55 51.8 
Sand/silt 10-20 125.7 0.744 0.80 74.8 
Clay 20-32 150.8 2.5 0.55 207.4 
Clay 32-40 - - 0 0 

 Qs = 334.0 

Base Resistance 

Computations for base resistance are performed using the soil at the base of the shaft. 
Nc = 6.0 [1 + 0.2(40/12)] = 10.0 > 9; use 9. 
qb = 9(2.5) = 22.5 tsf 
a = 0.0071 + 0.0021 (40/12) = 0.0141 
b = 0.45(5)0.5 = 1.01 
Fr = 2.5/[0.0141(144) + 2.5 (1.01)] = 0.55 
qbr = 0.55 (22.5) = 12.4 tsf 
AB = ( p/4 ) ( 122) = 113.1 ft2 
QB = 12.4(113.1) = 1402 tons. 

Total Resistance 
QT = 334 + 1402 = 1736 tons. 

Check Structural Capacity of Bell 

The ultimate load applied to the base of the bell, using dead load factor of 1.4 and live load factor of 1.7, is 
as follows: 

Qu = 1.4 (500) + 1.7 (140) - 334 = 604 tons. 

It is predicted that the ultimate structural capacity of a 45 degree bell with a 3:1 slope is 15 ksf.  A concrete 
strength reduction factor of 0.85 is applied to this value; however no other factors are applied. 
The ultimate structural capacity, using a material factor of 0.85 is thus the following: 

Qu = (15/2)(0.85)(113.1) = 721.0 tons. 
Ultimate Load Capacity 
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(a) based on the global F.S. = 1736/2.5 = 694.4 tons > 604 tons 

(b) based on the structural capacity of the bell and F.S. of 2.5 on side resistance: 334/2.5 + 721.0 = 854.6 
tons >> 604 tons 

∴ OK both ways, structural capacity of bell does not control. 

5.5.8 Comparison of Results 

Table 6.4 contains a comparison of the results obtained from hand computations against those from 
computer run in SHAFT. 

Category Manual Calculations 
(tons) 

Computer Analysis 
(tons) 

Deviation 

Side Resistance 334 334 0% 
Tip Resistance 1402 1361 -2.9% 
Total Capacity 1736 1695 -2.4% 

Table 5.4   Comparison of results for Example Problem 4 

5.5.9 Input and Output Data Files for Example 1 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Shaft2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 4 is the following: 

Examplev9-4-Silty Sand-Silty Clay.sf9d 

The output-data filename for Example 4 is the following: 

Examplev9-4-Silty Sand-Silty Clay.sf9o 

5.5.10 Graphical Results of Computer Analysis 

The resulting plots of ultimate skin friction and ultimate tip resistance versus depth provided by the 
computer program may be observed in Figure 5.17 and Figure 5.18.  Note that the load-transfer curve of 
skin friction versus depth in Figure 5.17 starts from about the 14-ft depth.  This is because the program was 
instructed to ignore skin friction at the top 5 ft and at the bottom 4 ft (one shaft diameter).  In addition, the 
program automatically ignores transfers in skin friction for the height of the bell, which is an additional 4 
ft. 
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Figure 5.17   Curve of Ultimate Skin Friction vs Depth for Example Problem 4. 

 

Figure 5.18   Curve of Ultimate Tip Resistance vs Depth for Example Problem 4. 
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5.6 Example Problem 5 – Strong Rock 
This is an example of a drilled shaft into strong rock. 

5.6.1 Soil Profile 

The soil profile is shown in Figure 5.19.  Only a small amount of water was encountered at the site during 
the geotechnical investigation. 

 
Figure 5.19   General soil description of Example Problem5. 

5.6.2 Soil Properties 

The dolomite rock found at the site has a compressive strength of 8,000 psi and the RQD was 100 percent.  
The Young’s modulus of the intact rock was estimated as 2.0 x 106 psi and the modulus of the rock mass 
was identical to this value.  Assume the spacing of discontinuities is about 7 ft and that the thickness of the 
discontinuities is negligible. 

5.6.3 Construction 

The excavation can be made dry.  A socket can be drilled into the strong rock and inspected carefully before 
concrete is poured. 

5.6.4 Loading 

The lateral load is negligible.  The working axial load is 300 tons.  No downdrag or uplift is expected. 

5.6.5 Factor of Safety 

An overall factor of safety of 3.0 is selected. 
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5.6.6 Geometry of the Drilled Shaft 

A diameter of 3.5 ft is selected, and a socket of 3.5 ft into the dolomite is specified. 

5.6.7 Hand Computations 

Assuming all load is transferred in end bearing and using the method proposed by the Canadian 
Geotechnical Society (1978): 

qa = Ksp qu 

3 / 0.5
10 1 300 /

s b
sp

s

c BK
cδ

+
= =

+
 

qa = (0.5) (8000) = 4,000 psi 

QB = (4,000) (π/4) (42)2 = 5.54 x 106 lb = 2,771 tons 
The value of end bearing includes a factor of safety of 3. 

5.6.8 Comparison of Results 

Table 5.5 contains a comparison of the results obtained from hand computations against those from 
computer run in SHAFT. 

Category Manual Calculations 
(tons) 

Computer Analysis 
(tons) 

Deviation 

Side Resistance ---- 90* ---- 
Tip Resistance 2771 2765 -0.2% 
Total Capacity ---- 2795 ---- 
*  Transfer in side friction is computed by the program for the upper clay layer 

Table 5.5   Comparison of results for Example Problem 5 

5.6.9 Input and Output Data Files for Example 5 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Shaft2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 5 is the following: 

Examplev9-5-StrongRock.sf9d 

The output-data filename for Example 5 is the following: 

Examplev9-5-StrongRock.sf9o 

5.6.10 Graphical Results of Computer Analysis 

The resulting plots of ultimate total capacity versus depth provided by the computer program may be 
observed in Figure 5.20 (for example of program features, this plot was created from the Computation > 
3D View and using the additional Show 3D View menu.  A large increase in total capacity can be observed 
in Figure 5.20 due to the larger end bearing in the strong rock. 
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Figure 5.21 includes a plot of axial load versus settlement.  As expected, the linear curve indicates that most 
settlement is due to the elastic compression of the shaft. 

 
Figure 5.20   Curve of Ultimate Total Capacity vs Depth for Example Problem 5. 
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Figure 5.21   Curve of Axial Load vs Settlement for Example Problem 5. 
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5.7 Example Problem 6 – Weak Rock 
This is an example of a drilled shaft in weak rock. 

5.7.1 Description of the Problem – Rough Socket 

Consider the shaft and soil profile shown in Figure 5.22.  The user is asked to compute the load-settlement 
relation for the socket, and to estimate the ultimate resistance at a settlement of wt= 25mm.  The socket is 
assumed to be rough.  The RQD for the sample is 100%. 

 
Figure 5.22   General pile and soil description for Example Problem 6. 

5.7.2 Hand Computations – Rough Socket 

1. Since the core recovery and RQD are high, assume that: Em= 115 qu. Note that Ec/Em= 100%. 
2. faa = fa = 2.4/2 = 1.2 MPa, or 1200 kPa (Technical Manual, Eq. 7-3). 
3. zc = 6.1 m (depth from top of concrete to middle of socket).  Considering concrete placement 

specifications: 
σn = 0.92γczc from figure 3.15, or 
σn = 0.92(20.4)(6.1) = 115 kPa = 1.14σp 

4. n = 115 kPa / 2400 kPa = 0.048 (Technical Manual, Eq. 7-7). 
5. L/D = 6.1 / 0.61 = 10. 
6. Ω =  1.14 (10)0.5  −  0.05[(10)0.5  −  1] log 100 −  0.44 =  2.94 (Technical Manual, Eq. 7-12) 
7. Γ = 0.37 (10)0.5  −  0. 15 [(10)0.5  −  1] log 100 +  0. 13, or 

Γ = 0.651 (Technical Manual, Eq. 7-13) 
8. Θf =  {[115 (2400) 2.94)]/[3.14 (6100 mm)(0.651) 1200]}wi 



CHAPTER 5 – Example Problem 6 – 5-28 
 

User’s Manual (Rel. Apr/2023)  SHAFT v2023 
 

Θf =  0.0542𝑤𝑤𝑡𝑡 (Technical Manual, Eq. 7-10). 
9. Kf = 0.048 + (0.0542wt − 0.048)(1− 0.048)/(0.0542wt − 0.096 + 1) 

Kf =  0.048 + (0.0542wt − 0.048) (0.952) / (0.0542wt +  0.904) (Technical Manual, Eq. 
7-11). 

10. At the end of the elastic stage, Θf = 𝑛𝑛 (implied by Technical Manual, Eq. 7-8). Therefore, 

wte =
n
Θ

=
0.048

0.0542
= 0.88mm, 

where wtesignifies wt at the end of the elastic stage. (Note that elastic response occurs only up 
to a very small settlement in this example.)  

11. qb = Λwt
0.67 (Technical Manual, Eqs. 7-14 and 7--15) 

qb =  {[(115) (2400) (10/11)} �
[200 (100.5  −  2.94)(11)]

[3.14(6100). 651] �
0.67

wt
0.67 

qb =  383.7 wt (mm)0.67 (kPa).  Note that Λ = 383.7. 
 

12. πDL = 11.7m2; πD2/4 = 0.2922m2 
13. Compute Qt corresponding to wte, signified by Qte: 

Qte = 11.7 (0.0542) (0.88) (1200)  +  (0.2922) (383.7) (0.88)0.67 
Qte = 670 +  103 =  773 kN (Technical Manual, Eq. 7-8). 
Note that at this point, 670 kN is transferred to the weak rock in side resistance and 103 kN is 
transferred in base resistance. (Qte, wte) is a point on the load-settlement curve, and a straight 
line can be drawn from (Qt= 0, wt= 0) to this point. 

14. Compute the values of Qtfor selected values of wton the nonlinear portion of the load-
settlement curve.  Numerical evaluations are made in the following table. 

(1) 
wt 

(mm) 

(2) 
Θf
= 0.0542wt 

(3) 
Kf(Step 9) 

(4) 
Qs
= �πDLKffaa 

(kN) 

(5) 
𝑞𝑞𝑏𝑏
= 𝛬𝛬𝑤𝑤𝑡𝑡0.67 

(kPa) 

(6) 
𝑄𝑄𝑏𝑏

= (
𝜋𝜋𝐷𝐷2

4
)𝑞𝑞𝑏𝑏 

(kN) 

(7) 
𝑄𝑄𝑡𝑡(𝑘𝑘𝑘𝑘)
= (4)
+ (6) 

5 0.271 0.229 3210 1128 330 3540 
10 0.542 0.373 5232 1795 524 5756 
15 0.813 0.472 6621 2355 688 7309 
25 1.355 0.599 8402 3316 969 9371 

Note that: 
qb(at wt = 25mm) = 3.32 MPa = 1.38 qu < qmax = 2.5qu 
Which is OK for definition of ultimate resistance. Based on base resistance, working load should 
be limited to qb= qu or wt should be limited to about 12 mm at working load. Note also that the 
compressive stress in the shaft at wt= 15 mm is 25,000 kPa (7309 kN/cross-sectional area), 
which may be approaching the structural failure load in the drilled shaft. 

 
15. The numerical values from steps 13 and 14 are graphed in Figure 5.23.  Also shown in Figure 

5.23 is the case with smooth socket for the same problem.  Hand computations for the case of 
smooth socket are included in the next section. 
 
The physical significance of the parameters Θf and Kf is evident from the numerical solution. Θf 
is a proportionality constant for elastic resistance for side shear, and Kf is a proportionality 
parameter for actual side shear, including elastic, plastic and interface slip effects. 
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5.7.3 Description of the Problem – Smooth Socket 

Consider the same example as before (shaft and soil profile shown in Figure 5.22).  The rock socket is now 
assumed to be smooth.  Estimate that φrc = 30 degrees.  The user is asked to compute the load-settlement 
relation for the socket, and to estimate the ultimate resistance at a settlement of wt = 25 mm. 

5.7.4 Hand Computations – Smooth Socket 

1. fa = faa = αqu 
2. Referring to Technical Manual, Figure 7-1, for 𝜎𝜎𝑛𝑛

𝜎𝜎𝑝𝑝
= 1.14, and qu = 2.4 MPa, we have α = 0.12. 

3. fa = faa = 0.12(2400) = 288 kPa 
4. qu/ σp = 2400 / 101.3 = 24, and Em/ σn = 115 (2.4) (1000) / 115 = 2400 
5. From Technical Manual, Figure 7-2, n = 0.11. 
6. Ω= 2.94 (unchanged); Γ= 0.651 (unchanged) 
7. Θf =  {[115 (2400) 2.94)]/[3.14 (6100 mm)(0.651) 288]}wt 

Θf =  0.226𝑤𝑤𝑡𝑡  (Technical Manual, Eq. 7-10). 
8. Kf = 0.11+[(0.226 wt - 0.11)(1- 0.11)]/[0.226 wt -2(0.11)+1];  

Kf = 0.11+(0.226 wt - 0.11)(0. 89)/(0.226 wt + 0.78). 
9. At Θf = n, wte = 0. 11/0.226 = 0.487 mm. 
10. qb = 383.7 (wt)0.67, where wt is in mm. and qb in kPa.  From Technical Manual, Eqs. 7-14 and 7-

15 (unchanged). 
11. Qte = 11.7 (0.226) (0.487) (288) + (0.2922) (383.7) (0.487) 0.67;  

Qte = 371 + 103 = 474 kN (Technical Manual, Eq. 7-8). 
12. Qte = 474 kN, wte = 0.487 mm is the point at the end of the linear portion of the load settlement 

curve. 
13. Compute the values of Qt for selected values of wt on the nonlinear portion of the load-

settlement curve. Numerical evaluations are made in the table below. 

 
14. The numerical values for smooth socket are graphed in Figure 5.23 in comparison with the 

values from rough socket to illustrate the effect of borehole roughness in this problem. Note 
again that qb< 2.5 qu 
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Figure 5.23   Curves of Axial Load vs Settlement for Example Problem 6 (rough and 

smooth sockets). Obtained from hand computations (O’Neill et al., 1975) 

5.7.5 Input and Output Data Files for Example 6 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Shaft2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filenames for Example 6 are the following: 

Examplev9-6-Weak Rock-Rough.sf9d 

Examplev9-6-Weak Rock-Smooth.sf9d 

The output-data filenames for Example 6 are the following: 

Examplev9-6-Weak Rock-Rough.sf9o 

Examplev9-6-Weak Rock-Smooth.sf9o 

5.7.6 Graphical Results of Computer Analysis 

The resulting plots of axial load versus settlement provided by the computer program for the cases of a 
rough socket with closed joints and a smooth socket with closed joints may be observed in Figure 5.24 and 
Figure 5.25 respectively. 
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Figure 5.24   Curve of Axial Load vs Settlement for Example Problem 6 using rough 

socket with closed joints. 

 
Figure 5.25   Curve of Axial Load vs Settlement for Example Problem 6 using smooth 

socket with closed joints. 
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5.8 Example Problem 7 – Decomposed Rock/Gravel 
This is an example of a drilled shaft in decomposed rock/gravel. 

5.8.1 Description of the Problem 

Consider the shaft and soil profile shown in Figure 5.26.  The user is asked to compute the load-settlement 
relation and to estimate the ultimate resistance. 

 
Figure 5.26   General pile and soil description for Example Problem 7. 

5.8.2 Hand Computations 

1. qmax(base) = 9.33 (0.23)(230)(8.79)0.80 
qmax(base) =  2806 kPa, (Technical Manual, Eqs. 6-6 and 6-7) 

2. Assessment of moduli: 
𝐸𝐸𝑠𝑠(𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 1) = 22(101)750.82 
𝐸𝐸𝑠𝑠(𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 1) = 76,600 𝑘𝑘𝑘𝑘𝑘𝑘  (Technical Manual, Eq. 6-9). 
𝐸𝐸𝑠𝑠(𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 2) = 𝐸𝐸𝑠𝑠𝑠𝑠 =  22(101)900.82 
𝐸𝐸𝑠𝑠(𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 2) = 89,000 𝑘𝑘𝑘𝑘𝑘𝑘  (Technical Manual, Eq. 6-9). 
𝐸𝐸𝑠𝑠𝑠𝑠(avg. )  =  [6.1(76,000) +  3.05 (89,000)]/9.15 
𝐸𝐸𝑠𝑠𝑠𝑠(avg. ) =  80,700 kPa. 
𝐸𝐸𝑠𝑠𝑠𝑠 = 22(101)1000.82 
𝐸𝐸𝑠𝑠𝑠𝑠 = 97,000 𝑘𝑘𝑘𝑘𝑘𝑘  (Technical Manual, Eq. 6-9). 

𝐸𝐸𝑏𝑏 = 𝐸𝐸𝑠𝑠𝑠𝑠
2.5

= 38,800 𝑘𝑘𝑘𝑘𝑘𝑘. 
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The numerical computation for load-transfer factors are included in Table 5.6. 

 
Table 5.6   Numerical computation of load-transfer factors for Example Problem 7 

𝐿𝐿
𝐷𝐷

=
15.25
0.915

= 16.7 

𝜆𝜆 = 2(1 + 0.4) [27,600,000]  =  868;  x =  2.5 (by convention). 

Ϛ𝜁𝜁 =  ln{[0.25 + (2.5(80,700/89,000)(1− 0.4)− 0.25)2.5]33.3} 

Ϛ𝜁𝜁 =  4.61. 

µ𝐿𝐿 =  2[2/(4.61)(868)]0.5
 (16.7)  =  0.747 

3. Compute the influence coefficient, I, according to Technical Manual, Eq. 6-10: 

𝐼𝐼 = 4(1 + 0.4)
1 + 8 tanh 0.747

𝜋𝜋(868)(1 − 0.4)(2.5)(0.747) 16.7

4
(1 − 0.4)(2.5) +

4𝜋𝜋 80,700
89,000 tanh 0.747

4.61(0.747) 16.7

 

= 0.19 

4. Qs max = π(0.915) [6.1 (162) +  3.05 (197)] 
5. Qs max = 4568 kN  (Technical Manual, Eq. 6-11, segmentally) 
6. 𝑄𝑄𝑡𝑡1 = 4568 𝑘𝑘𝑘𝑘

1− 0.191
2.5cosh(0.747)[(1−0.4)(1+0.4)]

= 4807 𝑘𝑘𝑘𝑘  (Technical Manual, Eq. 6-34). 

7. 𝛥𝛥𝑤𝑤𝑏𝑏 = (6413 −  4807)[0.6(1.4)]/[97,000/2.5)(0.915)] 
𝛥𝛥𝑤𝑤𝑏𝑏 = 38.0 𝑚𝑚𝑚𝑚  (Technical Manual, Eq. 6-14). 
 

8. 𝑤𝑤𝑡𝑡2 = 38.0 +  10.8 
𝑤𝑤𝑡𝑡2 = 48.8 𝑚𝑚𝑚𝑚 𝑎𝑎𝑎𝑎 𝑄𝑄𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡 = 6413 𝑘𝑘𝑘𝑘. 

9. The numerical values obtained from hand computations for 𝑄𝑄𝑡𝑡 versus 𝑤𝑤𝑡𝑡, are graphed in Figure 5.27 
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Figure 5.27   Curves of Axial Load vs Settlement for Example Problem 7. Obtained from 
hand computations (O’Neill et al., 1975). 

5.8.3 Input and Output Data Files for Example 7 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Shaft2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 7 is the following: 

Examplev9-7-Decomposed Rock-Gravel.sf9d 

The output-data filename for Example 7 is the following: 

Examplev9-7-Decomposed Rock-Gravel.sf9o 

5.8.4 Graphical Results of Computer Analysis 

The resulting plots of axial load versus settlement provided by the computer program may be observed in 
Figure 5.28. 
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Figure 5.28   Curve of Axial Load vs Settlement for Example Problem 7. 
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5.9 Example Problem 8 – Gravelly Sand & Gravel 
This is an example of a shaft drilled installed in gravelly sand and gravel strata.  The example used the 
values recommended by Rollins et al (2005) for computing the side friction in gravelly sand and gravel.  
The blow counts (SPT-N) in gravelly layers have to be greater than 25 in order to use the recommended 
criteria for gravelly soils. 

5.9.1 Soil Profile 

The soil profile is shown in Figure 5.29.  The water table is at a depth of 4 ft below the ground surface. 

5.9.2 Soil Properties 

N-values (blow counts per foot) from the Standard Penetration Test are included in Figure 5.29. 

 
Figure 5.29   General soil description of Example Problem 

5.9.3 Construction 

High-quality construction is assumed.  For gravelly soils, the contractor may start with the slurry method 
with a good control of slurry quality.  In some case the contractor may experience a loss of the slurry in the 
hole.  The contractor needs to be very careful to avoid the hole cave-in or collapse during operation in 
gravelly strata.  The contractor may need to use the casing method if the slurry method cannot work for a 
particular condition.  The contractor will have all the required equipment in good order and experienced 
personnel will be on the job for drilling holes in gravelly soils. 

5.9.4 Input and Output Data Files for Example 8 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Shaft2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 8 is the following: 

Examplev9-8-Gravelly Sand-Gravel.sf9d 
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The output-data filename for Example 8 is the following: 

Examplev9-8-Gravelly Sand-Gravel.sf9o 

5.9.5 Graphical Results of Computer Analysis 

The results of skin friction, tip resistance, and total capacity versus depth provided by the computer program 
were plotted together in Figure 5.30.  Figure 5.31 includes a plot of axial load versus settlement.  As 
expected, the full capacity can be fully mobilized at settlement of 0.6 inches. 

 

 
Figure 5.30   Curve of Ultimate Total Capacity vs Depth for Example Problem 8. 
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Figure 5.31   Curve of Axial Load vs Settlement for Example Problem 8. 
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5.10 Example Problem 9 – LRFD 
An example is presented in Appendix A of the NHI Drilled Shaft Manual (2010) to illustrate design of 
drilled shafts as foundations for a proposed replacement bridge.  This case study is included in Example 9 
for demonstrating the accuracy and convenience of using SHAFT in design of drilled shafts under axial 
loads based on the LRFD design procedures.  The proposed shaft is 8-ft in diameter and the total length 
(penetration) below the original grade (without scouring) is 192 ft. 

The factored axial, lateral, and moment forces at the foundation level were derived through a separate 
comprehensive structural modeling based on the LRFD design requirement.  The summary of factored loads 
on the proposed drilled shaft at the existing mudline is presented in Table 5.7. 

 

Table 5.7   Summary of factored loads for Example Problem 9. 

5.10.1 Soil Profile 

A generalized subsurface profile along the alignment of the bridge is shown in Figure 5.32.  Soils 
subdivided into general strata with identified layer thickness (Table 5.8) can be used in analysis.  The water 
table is at the existing ground surface.  Based on hydrologic studies at this location a scour depth of 38 ft is 
recommended for the design flood (100 year flood). 

 
Table 5.8   Summary of subsurface profile for Example Problem 9 

5.10.2 Soil Properties 

Soil properties for use in analysis including unit weight, internal friction angle (sand layers), undrained 
shear strength (clay layers), and others can be found in Figure 5.32.  Corrected N-value, (N1)60, for the sand 
layer at the tip of the drilled shaft is 41. 
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Figure 5.32   General soil description of Example Problem 9 

5.10.3 Hand Computations 

Calculations of nominal side and base resistance were carried out using a spreadsheet tool.  Table 5.9 shows 
the calculation results for the Strength I limit state of this example.  The table is divided into three areas: 
(A) side resistance in cohesionless soil layers; (B) side resistance in cohesive soil layers, and (C) base 
resistance.   
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Table 5.9   Calculations for Axial Compressive Resistance and Strength I Limit State for 

Example Problem 9. 

Computations for base resistance are performed using the soil at the base of the shaft. 

At the depth of 192 ft: 
NSPT= 41 
qB = (0.6) (41) = 24.6 tsf 
AB = 50.27 ft2 

QB = (50.27) (24.6) = 1,236.6 tons = 2,474 kips 

Total Nominal Resistance 
QU = 2469 + 2922 + 2474 = 7865 kips  

5.10.4 Comparison of Results 

Table 5.10 contains a comparison of the results obtained from hand computations against those from 
computer run in SHAFT. 
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Category Manual Calculations 

(kips) 
Computer Analysis 

(kips) 
Deviation 

Factored Side Resistance 2673 2643 -1.1% 
Factored Tip Resistance 1237 1237 0% 
Factored Total Capacity 3910 3880 -0.8% 

Table 5.10   Comparison of results for Example Problem 9 

5.10.5 Input and Output Data Files for Example 9 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Shaft2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 9 is the following: 

Examplev9-9-LRFD.sf9d 

The output-data filename for Example 9 is the following: 

Examplev9-9-LRFD.sf9o 

5.10.6 Graphical Results of Computer Analysis 

The results of skin friction, tip resistance, and total capacity versus depth provided by the computer program 
were plotted together in Figure 5.33.  Figure 5.34 includes a plot of axial load versus settlement.  As 
expected, the full capacity can be fully mobilized at settlement of 0.6 inches. 
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Figure 5.33   Curves of LRFD Geotechnical Capacity vs Depth for Example Problem 9. 
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Figure 5.34   Curve of Axial Load vs Settlement for Example Problem 9. 
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5.11 Example Problem 10 – Multiple Shaft Lengths 
This example is provided to investigate the SHAFT feature of multiple automatic computations with 
varying shaft penetrations.  For simplicity, this model uses the same shaft and soil example that were 
previously defined in Example Problem 1 of this manual (see Section 5.2). 

5.11.1 Soil and Shaft Properties 

The background information on soil strata, loads and shaft geometry are the same as those in Section  5.2 
of this manual.  For a combined view of the graphs of load-vs-settlement for multiple shaft lengths the 
original Example Problem 1 model was modified with the selection of Data > Evaluate Multiple Shaft 
Lengths with the information in Figure 5.35. 

 

Figure 5.35   Data > Evaluate Multiple Shaft Lengths for Example Problem 10. 

The specified parameters Figure 5.35 indicate to start with the maximum shaft length of 60 ft and calculate 
axial responses with 3-ft shorter penetrations to a final 42 ft shaft length (70% of the maximum). 

5.11.2 Input and Output Data Files for Example 10 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Shaft2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 10 is the following: 

Examplev9-10-Variable Length.sf9d 

The output-data filename for Example 10 is the following: 

Examplev9-10-Variable Length.sf9o 
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5.11.3 Graphical Results of Computer Analysis 

The interesting result plot in this example is obtained from the Graphics > Axial Load vs Settlement 
(averaged) menu that is shown in Figure 5.36.  The resulting graph is helpful for a designer that is trying 
to determine the optimum length for a shaft of a defined diameter. 

 
Figure 5.36   Axial Load vs Settlement (averaged) for Example Problem 10. 
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5.12 Example Problem 11 – Use of Design Charts 
This example is provided to investigate the SHAFT feature of ASD/LRFD Design Charts that provide 
responses for multiple shaft diameters as well as varying shaft penetrations.  For simplicity, this model uses 
the same shaft and soil example that were previously defined in Example Problem 2 of this manual (see 
Section 5.3). 

5.12.1 Soil and Shaft Properties 

The background information on soil strata, loads and shaft geometry are the same as those in Section  5.3 
of this manual.  For the generation of the Design Charts, the original Example Problem 2 model was 
modified with the selection of Data > ASD/LRFD Design Charts with the information in Figure 5.37. 

 

Figure 5.37   Data > ASD/LRFD Design Charts for Example Problem 11. 

The specified parameters Figure 5.37 indicate to start with the maximum shaft length of 60 ft and calculate 
axial responses with 3-ft shorter penetrations to a final 24-ft shaft length (controlled by the minimum 
limitation of 6-3 ft pile diameters plus 5-ft length of exclusion zones).  Default increments of 3-ft are used 
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in shaft length and 1-ft increments specified for shaft diameters.  The user may define any pile-head 
movements (settlements), the ones in the example were chosen at random. 

The variations of shaft diameters are specified under Data > Drilled-Shaft Properties where the it is 
defined to use a minimum of 3-ft OD and maximum of 7-ft OD.  The default increase of 6-in increments in 
shaft diameters is replaced by the value specified in the ASD/LRFD Design Charts menu. 

5.12.2 Input and Output Data Files for Example 11 

Users can read Section 2.1.1 (7) of this manual for reference on the location of placement of the input and 
output data files for the example files installed with this program.  The default installation directory is the 
following: (Root Drive) c:\Ensoft\Shaft2023-Examples.  The input data files for all examples presented in 
this manual are installed automatically with the program. 

The input-data filename for Example 11 is the following: 

Examplev9-11-Design Charts.sf9d 

The output-data filename for Example 11 is the following: 

Examplev9-11-Design Charts.sf9o 

5.12.3 Graphical Results of Computer Analysis 

The interesting results in this example are obtained from the Graphics > Design Chart (xx movement) 
plots.  One sample plot for 0.5-in movement at the top of shaft is shown in Figure 5.38.  The graph is helpful 
for a designer that is trying to determine the optimum diameter and length for a defined axial capacity. 
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Figure 5.38   Design Chart for 0.5-in Movement for Example Problem 11. 
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PROGRAM LICENSE AGREEMENT & DISCLAIMER 

IMPORTANT NOTICE:  The software you are about to install or previously have installed from Ensoft 
Incorporated (“ENSOFT”) is licensed only on the condition that you agree to the terms and conditions set forth 
below.  Please read the terms of this License Agreement & Disclaimer ("LICENSE") carefully. 
If you agree to be bound by the terms of this LICENSE, please check mark the box labeled “YES – I Accept the 
terms of this License Agreement!” during software installation so it can be installed on your computer. 
If you do not agree to the terms of this LICENSE, please check mark the box labeled “NO – I DO NOT Accept the 
terms of this License Agreement!” which will terminate the software installation. 
If the software is already installed and licensed, you have already agreed to the terms and conditions of this license, 
or someone has done so on your behalf. 
This LICENSE is a legal agreement between you (“USER”) – either an individual or a single entity– and ENSOFT 
for the ENSOFT software product that you are about to install or previously have installed (“PRODUCT”).  The 
PRODUCT collectively includes computer software and associated media, printed materials, hardware key (dongle), 
and electronic documentation.  The PRODUCT also includes any updates and supplements to the original 
PRODUCT that may have been produced by ENSOFT.  By installing, copying, downloading, accessing or otherwise 
using the PRODUCT, the USER agrees to be bound by the terms of this LICENSE.  If you (the USER) do not agree 
to the terms of this LICENSE, do not install or use the PRODUCT. 

SOFTWARE LICENSE & DISCLAIMER 

The PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual 
property laws and treaties.  The PRODUCT is licensed, not sold.  

1.  GRANT OF LICENSE 

This LICENSE grants you the following rights: 

1.1  INSTALLATION AND USE 

1.1.1  Single-User Licenses 

This software is licensed only to the USER (company or individual) whose name is registered with ENSOFT and for 
one specific physical site (“SITE”) registered with ENSOFT.  You may install and use the PRODUCT on any 
number of computers at the licensed SITE.  However, the PRODUCT is fully operational only in the SITE computer 
that carries the appropriate PRODUCT’s hardware key (“KEY”) that is used as software protection device. 

1.1.2  Network Licenses 

This software is licensed only to the USER (company or individual) whose name is registered with ENSOFT and for 
the specific physical site(s) (“SITE(S)”) and IP range registered with ENSOFT.  Each network seat that is purchased 
is provided with access for SITE(S) clients located within up to 2 subnets with unique third octets (“CLIENT 
SUBNETS”).  The minimum two-seat network license can be associated to a maximum of 4 CLIENT SUBNETS 
(within up to 4 unique third octets).  Purchase of additional network seats can extend the allowable range of 
CLIENT SUBNETS. 
The USER may install and use the PRODUCT on any computer in the licensed SITE(S) that is within the allowable 
CLIENT SUBNETS registered with ENSOFT.  Any one computer in the network can be designated as license 
server for the PRODUCT by carrying the appropriate PRODUCT’s hardware key (“KEY”) that is used as software 
protection device. 
This Network License strictly prohibits the PRODUCT to be used in or from computers located in office locations 
that are different than the licensed SITE(S) or outside the registered CLIENT SUBNETS.  Users in physical office 
locations other than the registered SITE(S) with ENSOFT are required to purchase additional licenses of the 
PRODUCT, even if the COMPANY is the same and/or if the additional offices are located in the same city. 
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2.  OTHER RIGHTS AND LIMITATIONS 

2.1  EDUCATIONAL VERSION 

If the PRODUCT was licensed with educational discounts, the use of the PRODUCT is strictly limited to academic 
or research activities of educators and/or students.  Any other usage voids all the rights under this LICENSE.  If in 
doubt, please contact ENSOFT to determine if you have a PRODUCT version that was licensed for educational 
purposes. 

2.2  LIMITATIONS ON REVERSE ENGINEERING, DECOMPILATION, AND DISASSEMBLY 

You may not reverse engineer, decompile, or disassemble the PRODUCT, except and only to the extent that such 
activity is expressly permitted by applicable law notwithstanding this limitation. 

2.3  RENTAL 

You may not rent, lease or lend the PRODUCT to third parties. 

2.4  TRADEMARKS 

This LICENSE does not grant you any rights in connection with any trademarks or service marks of ENSOFT. 

2.5  SUPPORT SERVICES 

ENSOFT shall provide you with limited support and maintenance services (“SUPPORT”) related to the PRODUCT 
during the initial year after purchase and for any additional SUPPORT term that the COMPANY elects to purchase 
for PRODUCT after the initial warranty period expires.   
Use of SUPPORT is limited to the ENSOFT policies and programs described in the PRODUCT’s User’s Manual, in 
documentation on the ENSOFT web site, and/or in other materials provided by ENSOFT. 
Any supplemental software code that may be provided to you as part of the SUPPORT or that is downloaded from 
the ENSOFT web site shall be considered part of the PRODUCT and subject to the terms and conditions of this 
LICENSE.  With respect to technical information you provide to ENSOFT as part of the SUPPORT, ENSOFT may 
use such information for its business purposes, including for product support, development or advertisements.  
However, ENSOFT will not utilize such technical information in a form that personally identifies the USER. 

2.6  SOFTWARE TRANSFER 

The initial user of the PRODUCT may make a permanent transfer of this LICENSE and PRODUCT and only 
directly to an end user.  This transfer must include all of the PRODUCT (including all component parts, the media 
and printed materials, any upgrades, this LICENSE, and the PRODUCT’s appropriate hardware KEY).  Such 
transfer may not be by way of consignment or any other indirect transfer.  The transferee of such one-time transfer 
must agree to comply with the terms of this LICENSE, including the obligation not to further transfer this LICENSE 
and PRODUCT. 

2.7  TERMINATION 

Without prejudice to any other rights, ENSOFT may terminate this LICENSE immediately if you fail to comply 
with the terms and conditions of this LICENSE.  In such event, you must destroy all copies of the PRODUCT and 
all of its component parts and provide evidence of such destruction in writing to ENSOFT within 3 business days. 

2.8  INDEMNIFICATION 

Within and during the terms of this LICENSE, ENSOFT warrants that the use of the initially provided PRODUCT 
does not infringe any patent, copyright, or trademark in the United States, and ENSOFT shall indemnify and hold 
USER harmless against any and all losses, damages and expenses, (including attorney’s fees) which USER may 
sustain or incur as a result of a breach of this warranty. 

2.9  CONFIDENTIAL INFORMATION 
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ENSOFT and the USER may have access to certain proprietary information and materials of the other that are 
confidential and of substantial value to the respective party, which value would be impaired if such information 
were disclosed to third parties ("CONFIDENTIAL INFORMATION").  ENSOFT and the USER agree that neither 
shall disclose any CONFIDENTIAL INFORMATION to any third party and shall take every reasonable precaution 
to protect CONFIDENTIAL INFORMATION. 
The provisions of this section shall not apply to any information which (i) is or becomes available to the public other 
than by breach of the LICENSE agreement by the receiving party, (ii) is rightfully received by receiving party from 
a third party without confidential limitations, (iii) is independently developed by receiving party's employees 
without access to CONFIDENTIAL INFORMATION, or (iv) is known to the receiving party without any restriction 
on its use or disclosure prior to first receipt of it from the disclosing party. 

3.  COPYRIGHT 

All title and intellectual property rights in and to the PRODUCT (including but not limited to any images, 
photographs, animations, video, audio, music, and text that may be incorporated into the PRODUCT), the 
accompanying printed materials, and any copies of the PRODUCT are owned by ENSOFT.  All title and intellectual 
property rights in and to the content which may be accessed through use of the PRODUCT is the property of the 
respective content owner and may be protected by applicable copyright or other intellectual property laws and 
treaties.  This LICENSE grants you no rights to use such content.  All rights not expressly granted are reserved by 
ENSOFT.  This PRODUCT is protected by the United States Copyright Law and International Copyright Treaty. 

4.  SOFTWARE DISCLAIMER  

Although the PRODUCT has been used with apparent success in many analyses, new information is developed 
continuously and new or updated PRODUCT releases may be written from time to time.  All users are requested to 
inform ENSOFT immediately if any errors are found in the PRODUCT.  As modifications, updates, or new versions 
are produced, the latest codes are posted on ENSOFT’s web site and made available to all visitors for free 
downloading. 
No warranty, expressed or implied, is offered as to the accuracy of results from ENSOFT’s PRODUCT.  The 
PRODUCT should not be used for design unless caution is exercised in interpreting the results and independent 
calculations are available to verify the general correctness of the results.  Users are assumed to be knowledgeable of 
the information in the printed documentation that is distributed with the digital media.  Users are assumed to 
recognize that the input parameters, eg., soil properties, increment length, tolerance on solution convergence, and 
many others, can have a significant effect on the solution and must be chosen carefully. Users should have a 
thorough understanding of the relevant theoretical criteria (appropriate references are suggested in the software 
documentation).  

5.  GOVERNING LAW 

This LICENSE is governed by the laws of the State of Texas and laws and treaties of the United States of America. 

6.  CONTACT INFORMATION 

Should you have any questions concerning this LICENSE or if you desire to contact ENSOFT for any reason, please 
use the following: 
Ensoft Incorporated 
3003 West Howard Lane 
Austin, Texas 78728 
United States of America 

NO OTHER WARRANTIES 
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TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, ENSOFT DISCLAIMS ALL OTHER 
WARRANTIES AND CONDITIONS, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED 
TO, IMPLIED WARRANTIES OR CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR 
PURPOSE, AND TITLE, WITH REGARD TO THE PRODUCT, AND THE PROVISION OF SUPPORT 
SERVICES.  THIS LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS.  YOU MAY HAVE 
OTHERS, WHICH VARY FROM STATE/JURISDICTION TO STATE/JURISDICTION. 

LIMITATION OF LIABILITY 

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL ENSOFT BE 
LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES 
WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, 
BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) 
ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE PRODUCT OR THE FAILURE 
TO PROVIDE SUPPORT, EVEN IF ENSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES.  IN ANY CASE, ENSOFT’S ENTIRE LIABILITY UNDER ANY PROVISION OF THIS LICENSE 
AGREEMENT SHALL BE LIMITED TO THE GREATER OF THE AMOUNT ACTUALLY PAID BY YOU 
FOR THE PRODUCT OR U.S.$1.00. 
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